Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have to make all the headings with 12 pt.s bold. How can i change predefined headings like list of tables generated with command \listoftables ?

(and content page of course)

Here is all packages i'm using.

\documentclass[12pt,a4paper]{article}

\usepackage[utf8]{inputenc}
\usepackage{titlesec}
\usepackage[turkish]{babel}

\usepackage[T1]{fontenc}

\usepackage{pslatex}

\usepackage{graphicx}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}

\titleformat*{\subsection}{\normalsize\bfseries}
\titleformat*{\subsubsection}{\normalsize\bfseries\itshape}

\titleformat{\section}
{\normalfont\fontsize{12}{14.4}\bfseries\MakeUppercase}{\thesection}{1em}{}
\usepackage[overload]{textcase} 
\usepackage[left=3.50cm, right=2.50cm, top=3.00cm, bottom=3.00cm,nohead,nofoot]{geometry}
share|improve this question
    
Welcome to TeX.SE. Please compose a fully compatible MWE that illustrates the problem including the \documentclass and the appropriate packages so that those trying to help don't have to recreate it. From the text of your question as it is now, it is impossible to help you. –  tohecz Apr 15 '12 at 21:07
1  
oh i didn't know that, sorry –  interlude Apr 15 '12 at 21:14
3  
You shouldn't be using pslatex, but rather mathptmx, in order to get Times-like fonts for your document. Chances are good that even without loading such packages the paper will be accepted with a "how nice this Times font" comment. :-) –  egreg Apr 15 '12 at 21:49
2  
@interlude anyways, +1 and thumbs up for you to want to typeset your project in LaTeX when Word is standard at your school! –  tohecz Apr 15 '12 at 22:03
1  
@tohecz Thanks. I literally HATE Word. It is a pain. No, it is agony! I tried to convince Word to do what i want for six hours at the last day of report deadline. I will not ever use Word again –  interlude Apr 15 '12 at 22:11

1 Answer 1

up vote 6 down vote accepted

You can use the titlesec package to customize the sectional unit titles. Since \listoffigures produces the title using \section*, the change in formatting for \section will affect this list (and every other element which internally uses \section or its starred variant). Since the 12pt class option is being used, it is enough to use \normalsize; the explicit option was used to be able to handle the case change in the titles. I also incorporated to my answer the settings for \subsection and \subsubsection that you included in your edited question:

\documentclass[12pt,a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[turkish]{babel}
\usepackage[left=3.50cm, right=2.50cm, top=3.00cm, bottom=3.00cm,nohead,nofoot]{geometry}
\usepackage[overload]{textcase} 
\usepackage{graphicx}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage[explicit]{titlesec}

\titleformat{\section}
  {\normalfont\normalsize\bfseries}{\thesection}{1em}{\MakeTextUppercase{#1}}
\titleformat{\subsection}
  {\normalfont\normalsize\bfseries}{\thesubsection}{1em}{#1}
\titleformat{\subsubsection}
  {\normalfont\normalsize\bfseries\itshape}{\thesubsubsection}{1em}{#1}

\begin{document}

\listoffigures
\section{Test}

\end{document}
share|improve this answer
    
it's not working. Can it be about babel turkish package? –  interlude Apr 15 '12 at 21:33
    
@interlude: then please edit your question and add a minimal version of your code in which the solution I proposed doesn't work; I ask for this minimal version because adding \usepackage[turkish]{babel} to my example, still shows the desired output, so something else is going on in your document. –  Gonzalo Medina Apr 15 '12 at 21:36
    
Ok. I've edited the question. Thank you. I dont understand how things effect each other in TeX –  interlude Apr 15 '12 at 21:44
    
@interlude: please see my updated answer. –  Gonzalo Medina Apr 15 '12 at 21:55
    
This is a great answer, thank you. Weirdly when i changed the order of packages it worked perfectly. For now =) –  interlude Apr 15 '12 at 22:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.