Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using biblatex-chicago to manage my bibliography but whenever I try to set a bibliography entry with the urldate field, it prints the word 'accessed' twice.

I have created a minimal example to demonstrate the problem. My source document looks like this:

\documentclass[a4paper]{article}
\usepackage[authordate,backend=biber]{biblatex-chicago}
\usepackage[australian]{babel}
\usepackage[babel]{csquotes}
\addbibresource{temp.bib}

\begin{document}

\cite{key}

\vfill\printbibliography

\end{document}

And temp.bib looks like this:

@online{ key,
  author = "Surname, Forename M.",
  title = "Title of an article",
  year = "2012",
  url = "http://www.test.com/",
  urldate = "2012-04-18",
}

When I compile this, I end up with a reference list that looks like this:

Surname, Forename M. 2012. Title of an article. http://www.test.com/
    (accessed [accessed 18 Apr. 2012]).

Can anyone see what is going on? Am I doing something wrong?

share|improve this question
    
How recently have you updated the biblatex-chicago package? –  Mico Apr 18 '12 at 4:04
    
@lockstep: I'm using TeX Live 2011 on Windows, so the version that comes with that. My log includes the line Package: biblatex-chicago 2011/08/31 v 1.6 biblatex style if that helps. –  ilium Apr 18 '12 at 5:57
4  
That's a bug in biblatex-chicago, in the cbx-files. The definition of url+date prints the text twice. \printtext[urldate]{\printurldate}} should be either only \printurldate or \printext[urldate]{\printfield{urlyear}...}. Notify the author. –  Ulrike Fischer Apr 18 '12 at 7:24
add comment

1 Answer

up vote 4 down vote accepted

It seems the babel is clashing with biblatex-chicago. Pass on the options american or english to babel like \usepackage[english]{babel}. According to biblatex-chicago documentation the option australian is not supported. (Refer section 6, page 95 to explore the possibilities of using australian english (if at all possible)). You need to have, it seems, the appropriate australian.lbx file (which is not supplied by biblatex-chicago by default) to get it working.

With \usepackage[english]{babel}, everything seems to work normally:

\documentclass[a4paper]{article}
\usepackage[authordate,backend=biber]{biblatex-chicago}
\usepackage[english]{babel} % changed the option to english
\usepackage[babel]{csquotes}
\addbibresource{temp.bib}
%
\begin{document}
%
\cite{key}
%\vfill % commented to show things close by. 
\printbibliography
%
\end{document}

enter image description here

share|improve this answer
    
Thanks, I missed that part of the manual. It's a shame it doesn't support Australian or UK English, though. –  ilium Apr 19 '12 at 3:11
2  
OK, the easiest workaround seems to be to leave the option as australian and add the line \DeclareLanguageMapping{australian}{cms-american} afterwards. That way only biblatex is using American English - I still get British hyphenation for the main document. –  ilium Apr 19 '12 at 3:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.