Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have just installed TeX Live 2011 using the install-tl Perl script on my extenal hard drive. What do I have to do next in order to get LaTeX up and running? EDIT: i am using ubuntu 11.10. Terribly sorry if the earlier version was vague, i thought mentioning the install-tl script would be specific enough. I type latex file.tex into the commandline, and it does not work.

share|improve this question
1  
As it stands this is a pretty vague question. For example, which operating system do you use? Did you try the 'standard' instructions for your OS, and if so what did not work? –  Joseph Wright Apr 18 '12 at 6:40
1  
Please read the installation instructions for Linux. –  Martin Schröder Apr 18 '12 at 7:02
    
You need to add the path to the TeX Live binaries to your PATH, as mentioned in the message printed at the end of the installation. (By the way, your edit is still terribly vague: what do you mean "does not work"? Please give us the actual error message if any, or explain what happens.) –  mpg Apr 18 '12 at 11:05
add comment

1 Answer

up vote 6 down vote accepted

It depends on which scheme you installed with TeX Live. You need at least the "basic" scheme to be able to typeset with latex. If you haven't specified anything during the installation, TeX Live by default resorts to its "full" scheme, which enables you to explore the full of TeX / LaTeX / ConTeXt / ... as the name suggests.

If you selected the "minimal" scheme or any scheme that doesn't include LaTeX, you can easily correct this with the following command:

tlmgr install scheme-basic

Next, check if you can compile the following minimal document:

\documentclass{minimal}
\begin{document}
 Hello world!
 \[ e=mc^2 \]
\end{document}

Save it to a file called test.tex, open a prompt and type: latex test.tex.

If you get an error, check the .log file for what LaTeX reports as missing and use tlmgr to install the missing parts. You can search the TeX Live repository with tlmgr search --global <searchterm>.

One final note: given you mentioned installing on an external hard drive, you should have run the TeX Live installation with the -portable option (either through ./install-tl -portable or by using the GUI and selecting the option). You might finally also need to add the TeX Live bin path to your PATH. How to do this depends on your platform -- on unix-based system, you will usually need to edit /etc/profile (system-wide configuration) or $HOME/.bash_profile (user-wide) and add the following lines

PATH=$PATH:/path/to/texlive/dir./bin
export PATH

Happy LaTeXing!

share|improve this answer
    
Thanks! I was searching for the path for the executable, as it were. –  Debanjan Basu Apr 18 '12 at 7:47
    
@Debanjan Inside the directory where you installed Tex Live, it's usually either bin/ or something like bin/<arch>/, e.g. bin/x86_64-linux. –  Xavier Apr 18 '12 at 16:26
    
after setting the path and exporting it i get the following -<br/> bash: /media/Eru Ilúvatar/texlive2011/bin/i386-linux/latex: Permission denied Now why is that? @xavier –  Debanjan Basu Apr 19 '12 at 4:34
    
@Debanjan The executable is there, but your users doesn't have the required permissions to run it. Make sure the hard drive was mounted by the user trying to run latex. If you are using a file system that supports permissions, make sure the user can read the Tex Live installation directory and has execution rights on the bin/<arch> folder contents. Either through cli if you know how to do this, or by typing sudo nautilus /media/Eru Ilúvatar/, right-clicking on texlive2011 and checking the permissions (read+execute for everyone). –  Xavier Apr 19 '12 at 7:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.