Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

What am I doing wrong? According to my understanding, these two formulae should look different (the second one should have a thin space):

\setupmathematics[autopunctuation=yes]

\starttext

$(2,5)$ versus $(2, 5)$

\stoptext

(I am using ConTeXt MkIV.)

share|improve this question
    
In math mode, TeX is set to ignore any discretionary spaces it finds in the input. –  Mico Apr 19 '12 at 8:17
    
@Mico LuaTeX is involved here, so there is/should be a callback to alter the behaviour I think (if you check the code, the option sets an \attribute). –  Joseph Wright Apr 19 '12 at 9:32
    
@JosephWright -- thanks for setting me straight on this issue. –  Mico Apr 19 '12 at 12:16
    
Even in MkII, it is (or at least I think so) supposed to take this space into consideration. –  mbork Apr 19 '12 at 12:16
1  
@mbrok: Looks like a bug in the current implementation. Please report it to the ConTeXt mailing list. –  Aditya Aug 5 '12 at 17:35
add comment

1 Answer

up vote 3 down vote accepted

What autopunctuation=yes did was make the comma behave the same as the period --- suppress the automatic thin space, for the benefit of those who use the comma as a decimal mark. Since last monday's beta, however, autopunctuation has the behaviour you expect: when it is set to 'yes', 2, 5 will get a thin space, and 2,5 will not. I have written a complete overview of autopunctuation settings over at the question Number kerning in ConTeXt math mode is different and worse than normal.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.