Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I tried to use bbding package for the enumitem symbols. I have added to my code:

\usepackage{bbding}
....
\begin{itemize}[label=\HandRight]

but I receive error

!pdfTeX error: /usr/local/texlive/2011/bin/i386-linux/pdflatex (file bbding10):
 Font bbding10 at 600 not found
 ==> Fatal error occurred, no output PDF file produced!

I have a complete version of texlive on Ubuntu. What other stuff is needed to put bbding in action?

UPDATE: The question was updated by useful comments in answers. As egreg assisted to figure it out; the problem was connected to user permission, as texlive had been installed under root.

share|improve this question
add comment

3 Answers

up vote 4 down vote accepted

The symbols are not math symbols, so $ is out of place.

You might want to correct the vertical placement of the symbols:

\documentclass{article}
\usepackage{enumitem,bbding,etoolbox,calc}

\makeatletter
\pretocmd{\@chooseSymbol}{\raisebox{-.5ex}[\height-.5ex][0pt]}{}{}
\makeatother

\begin{document}
\begin{itemize}[label=\HandRight]
\item abc

\item[\PencilRight] def
\end{itemize}
\end{document}

enter image description here

share|improve this answer
    
The problem is not vertical placement, but fonts. As I stated on the other answer, I get error Font bbding10 at 600 not found even with your code. Probably something is missing on my system; though I've complete version of texlive. –  All Apr 19 '12 at 9:15
    
@Ali Try issuing mktexpk bbding10 from the terminal. What happens? –  egreg Apr 19 '12 at 9:20
    
/root/.texlive2011/texmf-var/fonts/pk/ljfour/public/bbding/bbding10.600pk already exists. –  All Apr 19 '12 at 9:25
    
Are you really using your system as root? –  egreg Apr 19 '12 at 9:27
4  
@Ali Then no user will be able to use the created bitmaps. Never use TeX as root; do only maintenance. –  egreg Apr 19 '12 at 9:30
show 1 more comment

You probably need to install the (Ubuntu) package texlive-fonts-extra. Since I found this unanswered question while trying to resolve the same issue myself, I though it worth sharing what worked for me, despite the question being a little old.

share|improve this answer
1  
Welcome to TeX.SX! –  Heiko Oberdiek Sep 21 '13 at 17:06
add comment

Use it like this and don't use $...$:

\documentclass{article}

\usepackage{bbding}
\usepackage{enumitem}

\begin{document}
\begin{itemize}[label=\HandRight]
    \item Test
    \item Test
\end{itemize}
\end{document}

enter image description here

share|improve this answer
    
I got an error stating !pdfTeX error: /usr/local/texlive/2011/bin/i386-linux/pdflatex (file bbding10): Font bbding10 at 600 not found –  All Apr 19 '12 at 9:05
    
@Ali Do you get this error when you're running my code or yours? –  Thorsten Apr 19 '12 at 9:09
    
Your code, exactly the whole code you introduced. I don't have this problem with other packages such as wasysym, pifont, etc; but bbding. This is the reason that I tried $. –  All Apr 19 '12 at 9:12
    
@Ali I guess that there's a problem with your TeX Live installation. –  Thorsten Apr 19 '12 at 9:13
    
bbding uses bitmap fonts, which are built on demand. The problem might be in some setting of your TeX Live. Did you try any customization? –  egreg Apr 19 '12 at 9:18
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.