Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've got a large document which I wrote some time ago. It contains a bibliography for which I use biblatex:

\usepackage[style=authoryear-comp, maxnames=1, doi=false, url=false, backend=bibtex8]{biblatex}

For the encoding within the LaTeX-document, I use:

\usepackage[ansinew]{inputenc}
\usepackage[T1]{fontenc}

Last time I was working with the document (around a month ago), the encoding of bibliography items was not a problem and special characters were displayed in a correct way, e.g. the author name "Brydøy". However, now, it's only displayed as "Brydøy". If I simply put "Brydøy" into the normal text, it is displayed properly, but within the citations (in text citation as well as the bibliography) there seems to be something wrong with the encoding. I would appreciate help on how to fix this issue very much.

share|improve this question
1  
Try using backend=biber instead of bibtex8. Do you know what encoding your bib file is in? –  Alan Munn Apr 22 '12 at 14:57
    
@AlanMunn That's what I've been trying just before I saw your comment. :-) However, backend=biber doesn't help either. I export the references into the bib-file from EndNote, so I guess it should be in Unicode. –  AnjaM Apr 22 '12 at 17:27
    
You can specify the bibencoding explicitly as a biblatex option. See section 2.4.3.4 of the biblatex manual. Also, if you make a small UTF-8 encoded document, does the .bib file work correctly (with backend=biber and \usepackage[utf8]{inputenc})? –  Alan Munn Apr 22 '12 at 17:33
    
@AlanMunn Setting bibencoding=utf8 solved the problem (I didn't change \usepackage[ansinew]inputenc, though). Thanks a lot! If you'd put your comment as an answer, I will set it as accepted. –  AnjaM Apr 22 '12 at 17:45

2 Answers 2

up vote 16 down vote accepted

File encodings are not always easily determined, and so biblatex sometimes needs some help in deciding on the encoding of the bib file, especially if your bib file is encoded differently from your input file. But you can specify the bib file encoding directly as a biblatex option. If your bib file is UTF-8 encoded, you will need to use biber as the backend.

So you should load biblatex this way:

\usepackage[backend=biber, bibencoding=utf8, ... ]{biblatex}

(where ... is any other biblatex options.)

See section 2.4.3.4 of the biblatex manual for more details on bib file encoding issues.

share|improve this answer

This answer may not be what you're looking for, but you might give it a try.

In order to avoid any complication with special characters in my .bib file (or any of my tex files in fact), I usually use the code for the special char. I belive in the case of Brydøy, it would be Bryd\o{}y.

share|improve this answer
    
I added an empty group ({}) after \o. You are correct that \o produces an ø, but \oy will not work. –  Torbjørn T. Apr 22 '12 at 13:59
    
@wiwh, TorbjørnT. : The problem is that I already have a large .bib-file (246 entries at the moment) and it would take me a lot of time to go through all author names and to change the special characters. Furthermore, since I manage my bibliography with EndNote and subsequently export it to BibTeX format, I would need to change the characters within the EndNote library which would look weird and wouldn't be appropriate in case I would use this library in future for other document types rather than LaTeX. –  AnjaM Apr 22 '12 at 14:07
    
@AnjaM A simple find and replace would make it fairly quick to fix, but I agree that it isn't an ideal solution. (I didn't write this answer, by the way.) –  Torbjørn T. Apr 22 '12 at 14:10
    
@TorbjørnT. Sorry, I noticed that it wasn't your answer only after submitting my comment. –  AnjaM Apr 22 '12 at 14:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.