TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using TeXShop 2.43 on Mac OSX 10.6.8 and one of the latest LaTeX releases (I ran an update a few weeks back). My long implication arrows have a dot on either the top or bottom line (see attached photo). It happens with \Longrightarrow, \implies, and \Longleftarrow. The shorter arrows don't have it. It happens with all fonts sizes.

Is this a known issue? I googled it and I looked for it here, but I came up with nothing. Perhaps it's something with my system or version of LaTeX? On TeXShop under Preferences - Typesetting it says the default script is PDFTeX.

I'm sorry if I'm not supplying enough info here, I'm not very behind-the-scenes TeX savvy.

enter image description here

share|improve this question
I think it is a viewer issue. In adobe reader it is looking good for me. Which viewer you are using? – Harish Kumar Apr 22 '12 at 23:29
That's a good point. I use Skim, and I just tried it with @Harish Kumar Preview (don't have Adobe reader) and it looks the same. It sort of looks like an equals symbol melded with \Rightarrow. EDIT: Thank you for including the picture in the post. – eliya gwetta Apr 22 '12 at 23:49
it's definitely a viewer issue. i'm using firefox, and don't see any distortion until i enlarge the view to a really enormous magnification, at which point it's barely obvious that there is an overlap at the join of the extender and the arrow. but a warning -- for some fonts other than computer modern, where the design of the = is not intentionally matched to that of the arrow and there is not an explicit extender, there can definitely be a very noticeable discontinuity. – barbara beeton Apr 23 '12 at 13:18
up vote 10 down vote accepted

This is not a bug per se. Standard TeX math fonts do not have dedicated glyphs for these long arrows, so they are built from the corresponding short arrows and an extensible part.

For symbols that are assembled from various glyphs there have to be a minimum overlap between the parts to avoid possible gaps due to rounding, and what you see is the result of the overlapping part being rendered twice (as part of each side). Also note that this only affects on-line viewing, but printing should be OK, if you are concerned about that.

Other math fonts might not have issue with those particular symbols, if they provide dedicated glyphs for them, but I don’t know about such fonts offhand (STIX fonts have them, but their LaTeX support is not available yet). For modern TeX engines like LuaTeX or XeTeX, OpenType math fonts provide dedicated glyphs for long arrows and many similar symbols that are only constructed in traditional TeX setup.

share|improve this answer

What you're seeing is a result of viewer optimization. The 'long' arrow is composed of two characters, and at the meeting point glitches of the "smoothing" algorithm can occur.

Turning off smoothing or zooming to maximum should make the effect go away.

When viewed at the highest resolution you see that the symbol itself is totally smooth, so this is clearly a viewer bug.


share|improve this answer
That certainly did it (on skim it was ``Anti-alias text and line art"), but then the rest of the text in the document looked squiggly; kind of like a second grader wrote it. Changing the appropriate setting on Preview did the same thing. Perhaps I should switch to a better PDF viewer. – eliya gwetta Apr 23 '12 at 0:10
No, you'll getting the same effect with other readers. It's simply a side effect of visual optimization - as forinstance strange things happening to rules of arrays or \fbox - lines apparently vanishing or standing over. – Stephan Lehmke Apr 23 '12 at 0:19
So technically it is a bug in LaTeX (the long arrow could have been made smoother?) and the way it interacts with pdf viewers. Is there any workaround for it inside LaTeX? I know I shouldn't worry too much about this bug as it isn't viewable in print, however nowadays most people view documents electronically and not on paper. – eliya gwetta Apr 23 '12 at 1:21
@eliyagwetta No, the arrow itself is perfectly smooth, as you can see from my image at highest resolution. It is clearly a bug in the viewer's screen optimization. LaTeX is a system for generating print output, so it would be a bit far fetched to counteract viewer glitches. – Stephan Lehmke Apr 23 '12 at 4:47
Did you try with \documentclass[12pt]{article}? – egreg Oct 12 '13 at 9:18

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.