Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to use natbib for citation. Whenever I am trying to use more than two authors for citation instead of using "et. al. " , citation becomes number format instead of author year citation.

I am using it as

\usepackage[longnamesfirst, authoryear]{natbib} 

and

\bibliographystyle{plainnat}
share|improve this question

migrated from stackoverflow.com Apr 26 '12 at 16:18

This question came from our site for professional and enthusiast programmers.

    
Welcome to TeX.sx! Your question was migrated here from Stack Overflow. Please register on this site, too, and make sure that both accounts are associated with each other (by using the same OpenID), otherwise you won't be able to comment on or accept answers or edit your question. –  Werner Apr 26 '12 at 16:22
    
Also, can you post a minimal document that shows what you did. A minimal document with the two lines you give in your question will not produce the behaviour you describe. –  Alan Munn Apr 26 '12 at 17:13
add comment

3 Answers

The citation scheme you're using tells LaTeX to print the full list of authors at the first citation and the abbreviated one (with et al.) for the next. So

\documentclass{article}
\usepackage[longnamesfirst, authoryear]{natbib}

\begin{document}
A citation \citep{a}

Another \citep{a}

A citation \citep{b}

Another \citep{b}

\bibliographystyle{plainnat}
\bibliography{mybib}
\end{document}

with the following (fake) database mybib.bib

@article{a,
author={Alpher, A. and Bethe, B. and Gamow, G.},
title={A nice title},
journal={J. Niceties},
year=2013,
pages={1234-5678},
}
@article{b,
author={Alpher, A. and Bethe, B. and Gamow, G. and Delta, D.},
title={A nice title},
journal={J. Niceties},
year=2013,
pages={1234-5678},
}

will print

A citation [Alpher, Bethe, and Gamow, 2013a]
Another [Alpher et al., 2013a]
A citation [Alpher, Bethe, Gamow, and Delta, 2013b]
Another [Alpher et al., 2013b]

If you use \citep*, instead, you'll get always the full list:

A citation [Alpher, Bethe, and Gamow, 2013a]
Another [Alpher, Bethe, and Gamow, 2013a]
A citation [Alpher, Bethe, Gamow, and Delta, 2013b]
Another [Alpher, Bethe, Gamow, and Delta, 2013b]

There is also \citet*, for "textual citations".

share|improve this answer
add comment

The plainnat style should work as you expect. Here's an example:

\documentclass{article}
\begin{filecontents}{\jobname.bib}

@article{Sag1985,
    Author = {Ivan A Sag and G Gazdar and T Wasow and S Weisler},
    Journal = {Natural Language \& Linguistic Theory},
    Pages = {117-171},
    Title = {Coordination and How to Distinguish Categories},
    Volume = {3},
    Year = {1985}}
\end{filecontents}
\usepackage[longnamesfirst, authoryear]{natbib}
\bibliographystyle{plainnat}
\begin{document}
First mention \cite{Sag1985}. Second mention    \cite{Sag1985}

\bibliography{\jobname}
\end{document}

output of code

share|improve this answer
add comment

There are three ways that I know of which can help you.

The first one, the easy way, but I suppose the least satisfying, is by modifying your .bib files citation, leaving only the name of the first author followed by "and others". plainnat will automatically change the "and others" by "et al.".

The second way is to use another bibliography style that already includes this "trunking" function.

The third one involves making change in your plainnat.bst file. I will refer you to another answer on this stackexchange.

share|improve this answer
    
None of these solutions is really adequate or necessary. It's never a good idea to change the original bib file (you lose information). The plainnat style should work correctly, so the OP must be doing something else. –  Alan Munn Apr 26 '12 at 17:14
    
I totally agree with you. However, natbib, to my knowledge, does not provide a direct way to modify the number of authors (8 by defaults if I recall) to print before using "first author + et al.". –  wiwh Apr 26 '12 at 18:14
    
@wiwh -- that last statement is not correct. Check out, for instance, the makebst utility (written by Patrick Daly, the same person who authored natbib) for more information on how to change this threshold. –  Mico Apr 26 '12 at 18:57
    
@Mico This would involve modifying the .bst file, wouldn't it? In this case, the 3rd proposed solution also provides information on how to change this threshold. However, it is true that none of these propositions answers the OP's question. –  wiwh Apr 26 '12 at 19:39
    
@wiwh: Indeed, natbib -- or any other citation management package for that matter -- can't achieve it all by itself, i.e., without getting some "cooperation" from BibTEX, i.e., by choosing suitable settings in the bst file. But, as you note, this is not what the OP asked about. –  Mico Apr 26 '12 at 20:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.