Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a feeling that there is an obvious answer to this question that I'm somehow managing to miss. However, I've tried most of the commands in the biblatex documentation and I still can't figure it out.

What I want to do is reset the count for my footnotes and citations between chapters. In addition I also want ibid's, opcit's etc to start again at the beginning of a new chapter.

I'm currently using XeLaTeX with biblatex. My preamble is:

\documentclass[12pt,oneside]{book}

\usepackage[protrusion=true,expansion=true]{microtype}
\usepackage[style=verbose-trad1=true,natbib=true,sortcites=true]{biblatex}
\bibliography{bib.bib}

%Additional Stuff that I don't think should influenec the bibliography, but is here just in case
\interfootnotelinepenalty=10000
\usepackage{fontspec}
\usepackage{titlesec}
\defaultfontfeatures{Ligatures=TeX}
\usepackage{sectsty}
\allsectionsfont{\sffamily}
\setmainfont{Lyon Text Regular No. 2}
\setsansfont{Lyon Display Light}
\usepackage[margin=3.5cm]{geometry}
\pretolerance=5000
\tolerance=1000 
\usepackage{setspace}
\usepackage{graphicx}
share|improve this question

1 Answer 1

In the book class, footnotes (including citations as footnotes) are reset at the start of a new chapter by default. If it's different for you, you must be doing something your code snippet doesn't show. You could try to add the following to your document preamble (note that the starred version of \counterwithin doesn't add chapter prefixes):

\usepackage{chngcntr}
\counterwithin*{footnote}{chapter}

To reset "ibid." and similar expressions per chapter, use the biblatex package option citereset=chapter.

\documentclass{report}

\usepackage[style=verbose-trad1,citereset=chapter]{biblatex}

\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@misc{A01,
  author = {Author, A.},
  year = {2001},
  title = {Alpha},
}
@misc{B02,
  author = {Buthor, B.},
  year = {2002},
  title = {Bravo},
}
@misc{C03,
  author = {Cuthor, C.},
  year = {2003},
  title = {Charlie},
}
\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}

\chapter{foo}

Some text \autocite{A01}.

Some text \autocite{A01}.

Some text \autocite{B02}.

\chapter{bar}

Some text \autocite{B02}.

Some text \autocite{C03}.

\printbibliography

\end{document}
share|improve this answer
    
Thanks for your help. Having read that citations should automatically reset elsewhere I thought it must be something peculiar to me or a package class. However, I've just realized that it was because I was using \chapter*{Title} rather than \chapter{Title}. –  Timothy Monteath Apr 27 '12 at 3:23
    
@TimothyMonteath You're welcome! Please consider to upvote my answer (with the upward pointing arrow to the left of it; you need 15 reputation points before you can upvote) and possibly to accept it (by clicking on the checkmark). –  lockstep Apr 27 '12 at 3:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.