Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a template for a paper that I am using that produces dvi output when I run pdflatex on the input file. Whereas most of the papers that I have worked with produce pdf output when I run pdflatex.

I was looking at the log files for the two different papers and the one that produces dvi output includes the line:

(/etc/texmf/tex/latex/config/graphics.cfg
File: graphics.cfg 2009/08/28 v1.8 graphics configuration of TeX Live
)
Package graphics Info: Driver file: dvips.def on input line 91.

Whereas the one that produces pdf output contains the lines:

(/etc/texmf/tex/latex/config/graphics.cfg
File: graphics.cfg 2009/08/28 v1.8 graphics configuration of TeX Live
)
Package graphics Info: Driver file: pdftex.def on input line 91.

I am trying to figure out what the setting in that would cause this difference. The packages that are included for the two different papers are very similar, but I'm guessing it's related to one of them. So basically I want to figure out how to make pdflatex produce pdf output, and I'm wondering if the different driver file gives a hint as to what I should be looking at.

share|improve this question
    
Can you post the template? It would be much easier to help you if you give us the information. –  Boris Apr 27 '12 at 19:55
    
The template that I am using that is giving me problems is available here: microarch.org/micro44/files/micro2011AuthorKit.zip –  Gabriel Apr 27 '12 at 19:57
8  
You probably have left the first line in the template, which is %&latex. Remove it. Or launch pdflatex -no-parse-first-line –  egreg Apr 27 '12 at 20:16
    
thanks that solved my problem. –  Gabriel Apr 27 '12 at 21:23
    
@egreg: Please turn your comment into an answer. –  Werner Apr 28 '12 at 5:29
add comment

1 Answer

up vote 4 down vote accepted

In you tex file, you have put %&latex

%&latex
\documentclass[12pt,letterpaper]{article}

If you give %&latex this will produce dvi only. Just remove this line or put %&pdflatex.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.