Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Since I need to show a character in Czech, I use the following:

\usepackage[czech]{babel}

This makes everthing looks good including the Czech character, except for the following line showing unexpected result in the generated .pdf:

\usepackage[toc,page]{appendix}
(skip)
\begin{appendices}

becomes like below instead of printing "APPENDICES":

P RÍLOHA A

Any solution idea is appreciated.

share|improve this question

closed as too localized by Gonzalo Medina, Marco Daniel, percusse, Tom Bombadil, Claudio Fiandrino Sep 5 '12 at 7:59

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

6  
babel does not change the available characters, it changes the language elements such as section titles to the selected language (as well as setting up hyphenation for that language). If you just want a single Czech character no package should be needed. –  David Carlisle Apr 28 '12 at 16:01
    
@Gonzalo Medina thanks for attention. I updated the original question to try to provide info as much as possible. Just assuming the issue I had was related to the package I use? –  IsaacS Apr 29 '12 at 0:11
add comment

1 Answer 1

up vote 1 down vote accepted

Self response. Inspired by hint given by @David Carlisle, removing the usepackage phrase and adding the following line was enough for me.

\usepackage[utf8]{inputenc}

As I updated the original question, the issue occurred at the expressiong that is based on certain package. Thus I still don't know what the root cause is, nor whether the issue is associated with Czech package either.

share|improve this answer
1  
Glad you got it working. As for your original comment, the main aim of babel is to translate the headings. I do not speak Czech, but google translate suggests that (apart from the space after the P) PRÍLOHA A would be a plausible translation of appendix A (google translates it as Annex A). The space is (presumably) a bug in the babel support? –  David Carlisle Apr 29 '12 at 0:27
1  
Loading this package won't do anything regarding your problem, as the fixed words such as "Příloha" are defined independently from the input encoding. What you really need for Czech is \usepackage[T1]{fontenc}. Load also inputenc, but this is for inputting the text, and it's not related to output. –  egreg Apr 29 '12 at 8:40
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.