Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a BibTeX file with the following entry:

@article{Garbrecht1998,
  title={The treatment of flat areas and depressions in automated drainage analysis of raster digital elevation models},
  author={Martz, L.W. and Garbrecht, J.},
  journal={Hydrological processes},
  volume={12},
  number={6},
  pages={843--855},
  year={1998},
  publisher={Wiley Online Library},
  doi={{10.1002/(SICI)1099-1085(199805)12:6<843::AID-HYP658>3.0.CO;2-R}}
}

I'm creating my bibliography with natbib:

\documentclass[twocolumn]{article}
\usepackage[numbers]{natbib}
\usepackage[colorlinks,linkcolor=black,anchorcolor=black,citecolor=black]{hyperref}

\bibliographystyle{plainnat}
{\scriptsize
\bibliography{refs}}

\end{document}

You'll note that the DOI of the BibTeX entry contains some "bad" characters such as < and >. These should be displayed verbatim in the resulting PDF, but, instead, they are processed into large-angle symbols which cannot be copied and pasted.

How can I get BibTeX+natbib+LaTeX to give me my DOIs verbatim?

Thanks!

share|improve this question

1 Answer 1

\usepackage{doi} will let you typeset all DOI's "verbatim". It will make them links as well.

share|improve this answer
    
Or you can use \usepackage{uri} –  Harish Kumar May 2 '12 at 0:18
    
As @HarishKumar says, uri is another option. It seems to be newer too, so probably the preferred solution. –  qubyte May 2 '12 at 2:59
1  
Using the doi package with hyperref yields an option clash. Using uri with hyperref does not. If @amorua edits the answer to use uri, I will accept it. –  Richard Jul 18 '12 at 22:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.