Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

This is a bit of a follow-up question to: Is there latexmk functionality for LuaTeX?

I am trying to setup latexmk on Windows 7 together with LuaTeX but it does not work for some unknown reason. Latexmk in connection with pdftex runs without problems though. With the command line for luatex:

latexmk -pdflatex=lualatex -pdf test.tex

I get the following output:

Latexmk: This is Latexmk, John Collins, 30 March 2012, version: 4.31.
**** Report bugs etc to John Collins <collins at phys.psu.edu>. ****
Latexmk: applying rule 'pdflatex'...
Rule 'pdflatex': File changes, etc:
   Non-existent destination files:
      'test.pdf'
------------
Run number 1 of rule 'pdflatex'
------------
------------
Running 'lualatex  -recorder  "test.tex"'
------------
This is LuaTeX, Version beta-0.70.1-2012011814 (MiKTeX 2.9)
**

Other attempts at changing the latexmk command with the suggested values from the man-page also do not succeed (latexmk -pdf -pdflatex="lualatex %O %S" test.tex). Is there any chance of getting this to work?

share|improve this question
1  
Have you tried latexmk -lualatex test.tex? –  Mico May 3 '12 at 14:32
    
@Mico: latexmk gives -lualatex bad option as an error message then. –  Alexander May 3 '12 at 14:38
    
In TeXworks, with TeXlive, I've used the arguments listed in the TeXworks wiki, just replacing q/pdflatex with q/lualatex. Works fine for me. –  Torbjørn T. May 3 '12 at 14:46
1  
Looks like a miktex bug. lualatex test works fine but as soon as the recorder option is used it stops at the ` ** ` prompt. I will check for updates and if the bug persists I will make a report. –  Ulrike Fischer May 3 '12 at 15:59
1  
Until the bug is fixed, a workaround is to invoke latexmk with its -recorder- option. Its detection of file dependencies will be suboptimal, but only for difficult cases. –  John Collins May 3 '12 at 17:15
show 4 more comments

1 Answer

up vote 3 down vote accepted

It looks like a MiKTeX bug and I have made a bug report:

http://sourceforge.net/tracker/?func=detail&aid=3523285&group_id=10783&atid=110783

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.