Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using the beamer class for my thesis in Italian. Written Italian includes graphic accents, but beamer misunderstand them. This is a MWE of my problem:

\documentclass{beamer}
\mode<presentation>

\usetheme{Warsaw}
\usepackage[latin1]{inputenc}

\begin{document}
    Test: à 
\end{document}

All I get is an 'A' with a '~' symbol on top.

share|improve this question
3  
Have you saved in Latin-1 encoding? It works for me if you do, but fails as you describe when saved in UTF-8. –  Joseph Wright May 3 '12 at 20:46
    
where can I choose how to save file? –  Mariano May 3 '12 at 20:49
    
That depends on which editor you use. –  Joseph Wright May 3 '12 at 20:50
    
TexMaker: xm1math.net/texmaker –  Mariano May 3 '12 at 20:51

2 Answers 2

up vote 9 down vote accepted

The best way I found to put accented letters and ensure multiuser and multisystem compatibility is to encode the document in UTF8.

If you use texmaker Preferences -> Editor -> Font Encoding. Select UTF8.

Then in the document preamble write:

\usepackage[utf8]{inputenc}
share|improve this answer
    
Perfect. Thank you! –  Mariano May 3 '12 at 21:01
2  
I'm italian too, and I remember the pains when I started using LaTeX :) –  Edo May 3 '12 at 21:01

Try a semi-automatic input selection by the selinput package from the oberdiek bundle.

\documentclass[italian]{beamer}
\mode<presentation>
\usetheme{Warsaw}
\usepackage[T1]{fontenc}
\usepackage{selinput}     % Replacement for »inputenc«
\SelectInputMappings{     % Semi-automatic input selection
  agrave={à},             % by a list of selected glyphs
  egrave={è},             % see: http://partners.adobe.com/public/developer/en/opentype/glyphlist.txt
  Euro={€}
}
\usepackage{babel}

\begin{document}
  \begin{frame}
    Test: à ì
  \end{frame}
\end{document}
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.