Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I know this might not be a question for this forum but for SS; however, someone might give me a hint. This problem happens to me both in Ubuntu and in OS X.

When I want to install something (e.g., rubber or the gedit LaTeX plugin) I am required to install TeXLive components (texlive-base, etc.). The problem is that I already have the TeXLive system install---indeed, I have a newer version that the one found at the default system's repository (be that Ubuntu's or the Mac Ports'). What I have done to override this behaviour is to download the main files of the program I want to install (e.g., sudo apt-get download rubber), and then install it without dependencies (e.g., sudo dpkg -i rubber 1.1-2.4ubuntu1). Sometimes this works, but other times I get error messages regarding corruption in the repository database.

Is there a way of making my systems understand that I already got a newer version of TeXLive installed?

share|improve this question
1  
Have you followed all the instructions on the TeX Live Debian page, particularly about setting up an equivs package? –  Mike Renfro May 4 '12 at 0:35
1  
possible duplicate of How to install "vanilla" TeXLive on Debian or Ubuntu? –  Mike Renfro May 4 '12 at 0:36
2  
And for the Mac, why use MacPorts instead of MacTeX? –  Mike Renfro May 4 '12 at 0:49
    
@Mike, I found in StackExchange that someone got rubber working with MacPorts (since it is broken directly in OS X---at least to him and to me). That's why I tried it in that platform. –  NVaughan May 4 '12 at 2:27

2 Answers 2

up vote 1 down vote accepted

If you really want to prevent apt from installing TeX Live packages, you can try to create and install a dummy package as explained on the TeX Live Debian page (linked in Mike's first comment) or in this post from TeXblog. You may need to update the package list. Also, you should be aware (as mentioned in the comments of the texblog post) that this method doesn't work if any package you want to install has a dependency on a particular (or minimal) version of a texlive package: this is a limitation/feature of the Debian packaging system, versioned dependencies can't be satisfied by virtual packages.

So, my recommendation, unless you're very short on disk space, is to let apt install whatever texlive packages it wants to (you might restrict this a bit with the --no-install-recommends switch (or -R for aptitude) so that only hard dependencies are installed). Then all you need is to make sure your TeX live installation always comes first in the PATH, not only in your shell but also in your graphical environment. I've been using this solution for a while and everything works like a charm.

The right way to set the PATH depends on your system, but here are a few hints:

  1. You can install symlinks to programs from you local installation in /usr/local/bin by selecting the corresponding option at installation time, or running tlmgr path add (with sufficient privileges) later. Usually this is enough since /usr/local/bin is already in your PATH in an early position.

  2. On Debian-like systems, /etc/environment is a good place to set a system-wide PATH.

share|improve this answer

With Macports, the package lists texlive components as a dependency, and since the Macports version isn't installed it tries to remedy this by downloading and installing (you see it with other stuff that looks for things like python, and won't use the system install).

I don't really know much about Ubuntu, but I assume that it's the same thing.

share|improve this answer
    
Yeah, you're right. The problem is that there isn't any other way (at least for what I know) to get some programs or plugins installed in your system. For instance, to install AucTeX in Ubuntu (using the repositories) you're required to install TeXLive 2009---even if I've already got installed the 2011 edition. –  NVaughan May 4 '12 at 2:29
    
@NicolasVaughan Unfortunately not that I'm aware of. You can always play games with your PATH to try and make it find the "right" one, but that's not a good solution and probably doesn't work more then it does. –  Mike May 4 '12 at 2:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.