TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am new to the hyperref package. When I am not using the colorlinks option, it works well. (Loading other options like pdfborder presents no problem.) But, once I load the colorlinks option, the result becomes extremely bewildering: no errors, no warnings, and no output! :-(

Here are two pieces of sample code (the simplest ones):

Hello, world!
Hello, world!

The result: 0 error(s), 0 warning(s), 0 Bad Boxes(s), 0 page(s) (I don't know how to copy and paste the console output. Anyone knows how to do that?)

What's wrong with colorlinks?

Problem solved: As what @Ulrike commented, it was TeXnicCenter blocking the on-the-fly installation of color package. I switched to TeXworks, then the package is automatically installed. Now the output is fine.

share|improve this question

closed as too localized by Stefan Kottwitz May 6 '12 at 17:43

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Which version of hyperref do you use? hyperref has the option allcolors. – Marco Daniel May 6 '12 at 12:36
With colorlinks hyperref will try to load the color package (and some other files), so my guess is the files aren't yet installed and that (again) texniccenter is blocking the on-the-fly installation. Compile in texworks or on the command line. – Ulrike Fischer May 6 '12 at 12:44
Adding to what @Ulrike said: It's not necessary to switch over to TeXworks, I'd suggest to change the package installation in the MiKTeX Settings to on-the-fly. This way, TeXnicCenter will work just fine. (Btw, your MWE compiles just fine for me with TXC and MiKTeX, so it's most likely got something to do with installed packages and/or package versions.) – doncherry May 6 '12 at 12:54