Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I try that

\usepackage[bookmarks={false}]{hyperref}

But I receive error message

"Hyperref option clash"

So I instead that

\usepackage{hyperref}
\hypersetup{bookmarks={false}}

But it doesn't work.

Is that beamer class conflict with hyperref package?

share|improve this question
    
you probably have another package or the document class loading the hyperref package. compilable MWE would help here. However you could try adding before your \documentclass{} call the line \PassOptionsToPackage{bookmarks=false}{hyperref}. –  ArTourter May 6 '12 at 12:41
add comment

2 Answers 2

up vote 11 down vote accepted

Page 18 of the manual:

\documentclass[hyperref={bookmarks=false}]{beamer} 
share|improve this answer
add comment

The beamer class doesn't conflict with the hyperref package, but it already loads that package with different options. You could use \PassOptionsToPackage to specify options before the class and hyperref are loaded:

\PassOptionsToPackage{bookmarks={false}}{hyperref}
\documentclass{beamer}
\begin{document}
\frame{text}
\end{document}
share|improve this answer
    
@egreg: Yes, I would expect that. However, the OP tried that. Furthermore, I mentioned this general approach because it could be used for other packages, which don't provide such a convenient \...setup command as hyperref does. –  Stefan Kottwitz May 6 '12 at 12:47
    
It doesn't work –  pythonee May 6 '12 at 12:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.