Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a problem with the MiKTeX package manager. I receive the message:

The MiKTeX web service has rejected your request. 
Possible reason: too many requests arriving from your IP address.

and:

HTTP Error 503. The service is unavailable.

I cannot even choose another repository. Maybe this all was caused by my having killed the process on my first try with ctrl-alt-del? Can it be that at the server a "zombie" of that killed process is still present? Will the problem go away by itself?

share|improve this question
    
I should add to my problem description that the exact problem was posted on latex-community.org/forum/viewtopic.php?f=9&t=1456. But no helpful advice was given there. –  Wolfgang May 7 '12 at 17:02
    
I'm having the same problem, looks like the server is down. –  user14321 May 7 '12 at 17:52
    
I have the same problem. I think some server are down. –  user14322 May 7 '12 at 17:53

3 Answers 3

The MiKTeX packages are downloaded from are larger set of mirror servers. It appears that the one you got connected to is either down or doesn't accept multiple connections to him. Simply choose a different mirror from the mirror list and try again with it. Also simply waiting a little bit should fix it, because defect servers are automatically removed from the mirror list after a while or might recover.

share|improve this answer
1  
Is "choosing a mirror" the same as "change the repository"? If so, I cannot do so, as the same error message appears. Could this problem maybe be related to the connection settings? Should I change something in the settings? Use a proxy? –  Wolfgang May 7 '12 at 18:50
    
Yes, mirror and repository is the same thing. If this doesn't help simply wait a day or so. Other people have the same issue, so it's not on your side. –  Martin Scharrer May 7 '12 at 18:58
    
I will do so. Let's see tomorrow. Still, I am wondering if it could be related to the settings of my miktex or my computer. What is the intended use of the proxy settings in the "change package repository" menu anyway? –  Wolfgang May 7 '12 at 19:31
    
@Wolfgang: Some people are required to use proxies to connect to the internet, e.g. if they are being a company firewall etc. –  Martin Scharrer May 7 '12 at 21:34
1  
OK: I tried again this morning and everything worked fine this time. I could both install packages and change the package repository. Thanks for the help! –  Wolfgang May 8 '12 at 7:07

Sadly I got the same prob. Just lay back an drink some tea. If you urgently need a package you can always manually download it via http://mirror.ctan.org/macros/latex/contrib. Dont forget to refresh the index with the MiKTeX setting tool if you do so.

share|improve this answer
    
Thanks! I followed your advice, which is ok in the meantime. –  Wolfgang May 7 '12 at 19:03

This is from the page MiKTeX Package Repository:

How it works

The primary package repository is a directory on my computer and its contents is not directly accessible from the Internet. From time to time (say once a week) I "release" the package directory by uploading its contents to the CTAN directory systems/win32/miktex, which is actually mirrored.

The MiKTeX web service is used by the MiKTeX package manager to retrieve the list of valid package repositories. In order to reduce resource usage on the server, the web service stalls (and possibly rejects) excessive requests arriving from the same IP address.

That means the rejections are made so as to reduce the load on the servers.

Solution:

  1. If you can hide your IP (somehow!), then things should work as usual.
  2. If you can change your IP (you have to find a way if possible), then you are in business.
  3. Wait for some time, let us say minimum one day and then try.
share|improve this answer
    
I think in this case, it wasn't because of excessive requests. –  svick May 8 '12 at 12:31

protected by Martin Scharrer May 7 '12 at 18:04

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.