Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using LaTeX for four days now and I have a problem with the biblatex-apa style.

Here is the important part of my header:

\documentclass[
    a4paper,
    12pt,
    %twocolumn,
    headings=normal     % big,small
]{scrreprt} 
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[english,ngerman]{babel} 
\usepackage{geometry}
\geometry{
    a4paper,
    top=3.5cm,
    left=2.3cm,
    right=4.5cm,
    bottom=4.5cm,}

\usepackage[babel]{csquotes}
\usepackage[style=apa,backend=biber]{biblatex}
\bibliography{literatur}        
\DeclareLanguageMapping{ngerman}{ngerman-apa}

\begin{document}

\cite{example}

\end{document}

I'm using Texmaker and BibTeX. And it doesn't work. :( There are undefinded references and I should rerun Biber on the file (biblatex) apa (biblatex) and rerun LaTeX afterwards. I already tried to run bibtex, latex, bibtex, latex, but nothing changed.

Can somebody please help me!

share|improve this question

1 Answer 1

up vote 9 down vote accepted

Short: If you define backend=biber then you should actually use biber as your backend and not bibtex. Or you can define backend=bibtex and use bibtex.

Longer: biber is a program specifically meant to replace bibtex (the program) for biblatex. It does everything bibtex does and much more. Among other things it can handle UTF8 encoded files flawlessly, supports advanced sorting mechanisms and can do all kind of funky on-the-fly manipulation. If there's nothing which forces you to use bibtex, use biber (which is part of TeXLive and MikTeX)

BTW: The sequence is latex, biber (or bibtex), latex. You always must run latex first because only after a latex run, the system actually "knows" that there are references.

EDIT: Since biblatex-apa requires biber, using the BibTeX backend is not an option in this particular case.

share|improve this answer
    
Thanks a lot. But how can I get biber? I already searched in the web and am a bit confused now. Is biber the same as biblatex? How does my header change? Is this the correct part of the header: \usepackage[babel]{csquotes} \usepackage[style=apa,backend=biber]{biber} \bibliography{literatur} \DeclareLanguageMapping{ngerman}{ngerman-apa} \begin{document} \cite{example} \end{document} –  Markus May 7 '12 at 20:50
    
@Markus -- Change \bibliography{literatur} to \addbibresource{literatur.bib}. Biber is available here. Biber is a program, like BibTeX, but is designed specifically for biblatex (which is a 'package' for LaTeX): biber can only be used with biblatex, which is not true of bibtex. –  jon May 7 '12 at 21:56
    
As I wrote: You can use bibtex but then you have to change the backend directive. If you leave your preamble as it is, you must use biber which is part of both TeXLiveand MikTeX. If you have troubling finding it, we need to know what distribution and what editor you actually use. While the use of \addbibresourceis encouraged, this is not the cause of your problem. \bibliography will work as well. –  Simifilm May 8 '12 at 4:34
    
I'm using Texmaker from MikTex and I think biber should be already installed. Even if i let compile the header with this part: \usepackage[babel]{csquotes} \usepackage[style=apa,backend=biber]{biblatex} \addbibresource{literatur.bib} \DeclareLanguageMapping{ngerman}{ngerman-apa} i get three warning (citation undefined, undefined references, please rerun biber on the file). But it doesn't matter how often I compile with pdflatex and bibtex, the warnings persist and biblatex doesn't work. –  Markus May 8 '12 at 6:11
    
Again: if you have backend=biber in your document, don't use bibtex but biber instead. I'm not a TeXMaker user, but after a short glimpse at the program it looks like you must change the settings for the Bib(la)tex command. In my vanilla installation it says "/usr/texbin/bibtex" %.aux. You probably have to change this to "/usr/texbin/biber" %.bcf (not tested, and this is with TeXMaker under TeXLive on OSX. YMMV). Or, if you want to continue using bibtex, change the backend line in your .tex document to backend=bibtex. –  Simifilm May 8 '12 at 7:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.