TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a MiKTeX installation running on Windows Vista, and whenever I try to run initexmf, I get the following error message

initexmf: Windows API error 5: Access is denied. initexmf: Data: C:\Users\Public\Documents\My Music

The strange thing is, I don't have any latex documents in the My Music folder. Does anyone know what the problem might be? I don't have this problem on Windows XP computers, and I have tried disabling UAC, but to no avail.

share|improve this question

I finally solved the problem by including the --admin flag.

initexmf --admin


share|improve this answer
But with the --admin switch you are calling a different tool. E.g. initexmf --admin -u will (as far as I know) not update the FNDB of your local tree. At my opinion you should really try to find out, what's going on e.g. by setting a trace: miktex.org/diagnosing. Btw: I sometimes get API-errors when miktex options is open in the background. – Ulrike Fischer Nov 28 '10 at 15:11
@Ulrike: yeah, it sometimes mo.exe will lock the fndbs for some reason :-( – SamB Dec 19 '10 at 23:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.