Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Got the following
Document:

\documentclass[a4wide,11pt]{report}

\usepackage[dutch,english]{babel}
\usepackage{blindtext}
\usepackage{biblatex}

\usepackage{hyperref}

\bibliography{Bibliografie_AG.bib}

\begin{document}

Something blablabla \citep{MendeleySearch}

\printbibliography
\end{document}

Bibliografie_AG.bib (e.g.):

@online{MendeleySearch,
 author               = {John Doe},
 month                = {5},
 title                = {Mendeley | Search},
 url                  = {http://www.mendeley.com/research-papers/},
 year                 = {2012},
 }

I'm using biblatex to reference URLs. But now I cannot use /citep or something listed here.

Is there any way to make this happen?

share|improve this question
1  
The command \citep is provided by the natbib package. Do you maybe want to load the biblatex package with the natbib=true option to make it emulate the \citep command? –  Mico May 10 '12 at 10:02
    
\usepackage[natbib]{biblatex} is now 'not giving errors' but, \citep{} doesn't give me the output between (Author, Year) as stated. –  Highmastdon May 10 '12 at 10:09
    
I'm not sure if I understand what you mean by "the output between (Author, Year)". Are you looking to get a comma inserted between the author and year components? If so, be sure to set the instruction \nameyeardelim{, } somewhere in the preamble. (The default is a simple interword space.) –  Mico May 10 '12 at 10:22
    
I'm referring to: en.wikibooks.org/wiki/LaTeX/Bibliography_Management#Natbib where is stated that \citep{author93} should give this (Author, 1993) –  Highmastdon May 10 '12 at 10:25
    
Have you tried the instruction \renewcommand\nameyeardelim{, } in the preamble of your document? –  Mico May 10 '12 at 10:31

2 Answers 2

up vote 1 down vote accepted

The following, simplified form of your MWE works fine if one remembers to run bibtex after the first LaTeX pass, and then run LaTeX twice more:

\documentclass[11pt]{report}

\usepackage[citestyle=authoryear,natbib=true,backend=bibtex]{biblatex}
\renewcommand\nameyeardelim{, }

\bibliography{Bibliografie_AG.bib}

\begin{document}

Something blablabla \citep{MendeleySearch}, \ldots

As shown by \citet{MendeleySearch}, \ldots

\autocite{MendeleySearch} % same output as \citep

\printbibliography
\end{document}

enter image description here

share|improve this answer

As mentioned in the comments, \citep is not a biblatex command. It is a natbib command. You can get biblatex to work with \citep by using the option natbib=true. However, you could also try biblatex's own command: \parencite.

For author year citations, you should also use one of the author year bibliography style options:

\usepackage[natbib=true, style=authoryear]{biblatex}

See section 3.3 of the biblatex manual for a list of styles. These include: authoryear, authoryear-comp, authoryear-ibid and authoryear-icomp.

share|improve this answer
    
Yes I know that as stated here but as I also explained, it doesn't work. Even \parencite does not work. –  Highmastdon May 10 '12 at 12:09
1  
@Albert First "It doesn't work" doesn't help us: what appears where you expect the citation? Second, see my update. You need to tell biblatex that you want author (year) citations… –  Seamus May 10 '12 at 12:53
    
Thanks a lot. "it doesn't work" should be: It just gives me [1] with the hyperlink to the bibliography. ;) –  Highmastdon May 10 '12 at 13:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.