Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I use the apa-good style, bibtex and the cite package and try to make a text-citation. Unfortunately, it always comes up with a "&" instead of an "and". E.g. Lagos & Wright (2005) instead of Lagos and Wright (2005). Can you help?

share|improve this question
1  
Welcome to TeX.sx! Please add a minimal working example (MWE) that illustrates your problem. –  egreg May 11 '12 at 9:44
add comment

3 Answers

First off, you should probably not load the cite package -- which is designed for numeric-style citations. Have a look at the natbib package, which is set up to make authoryear-style citations very straightforward.

Second, regarding your preference for using and instead of & as the conjunction between authors' names: Make a copy of the file apa-good.bst and call it, say, myapa-good.bst. Open the new file with a plain text editor and replace the four instances of \& (note the backslash character, \) with and. They should be located inside the functions format.names, format.names.ed, format.full.names, and format.lab.names. Save the file myapa-good.bst and update TeX's filename database if necessary (how to do so depends on the TeX distribution you use; for TeXLive, the update command is texhash). Finally, be sure to include the command \bibliographystyle{myapa-good} from now on in your documents.

Addendum prompted by the OP's follow-up queries: You mention you use MikTeX. To update its filename database, fire up MikTeX's "Settings" app (look under "Windows Start Button -> All Programs -> MikTeX -> Maintenance"), click on the "General" tab, and click on the "Refresh FNDB" button. To use the natbib package, include the instruction \usepackage{natbib} in the preamble. Depending on how you MikTeX was set up on your computer initially, the natbib package will either already be installed or it will be downloaded and installed "on the fly" the first time that MikTeX tries to load it. For the "on the fly" installation method to work, you'll of course need a connection to the Internet where the computer is not behind a firewall that disables access to external file databases.

share|improve this answer
    
Thanks a lot so far - I have made the changes in the apa-good.bst. But still doesn't work - do I have to download the natbib package or is it enough if I have \usepackage{natbib} in my TeX file? and how do I update the database with MikTex? Thanks –  Betzi May 11 '12 at 12:05
    
@Betzi: Please see the addendum to my initial answer. –  Mico May 11 '12 at 13:28
add comment

There are two strategies.

Easy

Put \renewcommand{\&}{and} into your preamble. If you have no appearances of \& in your document other than in the bibliographical references, then this will do.

Less easy

Copy apa-good.bst into myapa-good.bst in the same folder as your document and change, in the copy, all appearances of \& into and (it appears four times). Then use \bibliographystyle{myapa-good}.

Comment

A style that uses "&" for joining author names doesn't deserve to be called "good".

share|improve this answer
    
A global replacement of \& with and may be "too easy", i.e., too much of a good thing, as it's not uncommon to have instances of & in the titles of books and articles. –  Mico May 11 '12 at 11:42
    
@Mico I know, that's why I added a proviso. –  egreg May 11 '12 at 11:45
add comment

This question is unclear; but I don't think it is simply asking to change "&" to "and".

As I understand it, APA style uses "&" to link author names in the bibliography and parenthetical citations [(Lagos & Wright, 2011)], but "and" in text citations [Lagos and Wright (2011)]. I believe that apa-good is a (rather old) file designed to work with natbib, so I'd expect you to be using a \citet{} to get the citation you are bothered with. (I'm puzzled by your reference to using the cite package, which just doesn't seem appropriate to APA style at all.)

If I understand the rather unclear question correctly, I don't think that changing all the instances of "&" in (a copy of) apa-good.bst will therefore do what you want, because it will change them in both text citations (where you want a change) and in parentheticals (where you don't). If that is what you want to do then others have shown how to do it.

But if what you want is full APA compliance, I'd take a different approach.

Although it's not my field, if what you want is APA-compliance, why not use a more up-to-date package. apacite seems to be actively maintained, and is compatible with natbib commands if you load it with the natbibapa option, so you shouldn't need to alter your document. I think it will take care of the immediate problem you are having, and avoid others.

share|improve this answer
    
Thanks - it all worked :-) –  Betzi May 11 '12 at 12:40
    
@Betzi -- If you believe that one of the answers has fully addressed your questions, don't forget to formally "accept" that answer by clicking on the "check mark". –  Mico May 11 '12 at 15:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.