Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am creating a blackletter font and would like to use it with LuaLaTeX, which works fine for nearly everything so far, except for using contextual alternative glyphs (in this case, r→ꝛ after round letters).

Ousia reports that as a bug for fontspec, and gets the answer that it seems to be a bug in luaotfload. Is there a workaround or bugfix somewhere out there?

share|improve this question

closed as too localized by Speravir, percusse, Stefan Kottwitz Apr 6 '13 at 23:03

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Is the issue loading contextual alternative glyphs for any font or for the one mentioned in the bug report (Theano Didot). I have found that fontspec can be a bit temperamental when it comes to loading alternative glyphs. For example, I can't call alternative glyphs of Linux Libertine with Alternate=0, but have to use Style=Alternate instead. –  Jörg Jul 10 '12 at 8:47
    
I've downloaded Theano Didot and according to Photoshop's font selection it does not have alternative glyphs. –  Jörg Jul 10 '12 at 13:07
    
I did not try it with Theano Didot (I just linked to that bug report because it looks like the same problem) but with a font I'm working on myself, and I definitely want to use the calt table, which should be activated by Contextuals=Alternate or RawFeature={+calt} (as in that bugreport), both of which did nothing. –  Anaphory Jul 11 '12 at 10:12
1  
Okay, I've tried with Junicode that loads the calt table by default, and unfortunately that bug still exists in luaotfload 1.27. So it appears you would have to use XeLaTeX. Have you tried reviving this issue on the LuaTeX Mailing List? –  Jörg Jul 12 '12 at 10:17
1  
@Anaphory: Any progress with XeLaTeX/LuaLaTeX? Did you try the recent versions of xetex/luatex? –  Martin Schröder Apr 6 '13 at 22:08

Browse other questions tagged or ask your own question.