Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I get the following error when I try to typeset a beamer document.

kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 0+525/600 --dpi
525 mathkerncmssi8 gsftopk: fatal: map file `cid-base.map' not found.
mktexpk: don't know how to create bitmap font for mathkerncmssi8.
mktexpk: perhaps mathkerncmssi8 is missing from the map file.
kpathsea: Appending font creation commands to missfont.log.  ) !pdfTeX
error: pdflatex (file mathkerncmssi8): Font mathkerncmssi8 at 525 not
found  ==> Fatal error occurred, no output PDF file produced!

But if I remove sansmathaccent.sty from the TeX Live tree, the document typesets fine. Here is a minimal working example.

\documentclass[10pt]{beamer} 
\begin{document} 
\begin{frame}{A very short beamer document} 
$e^{i\pi}+1=0$ 
\end{frame} 
\end{document}
share|improve this question
    
Welcome to TeX.SX! On my system it compiles fine. What system and TeX distribution are you using? –  egreg May 14 '12 at 20:13
    
this works fine for me \documentclass[10pt]{beamer} \usepackage{sansmathaccent} \begin{document} \begin{frame}{A very short beamer document} $e^{i\pi}+1=0$ \end{frame} \end{document}, perhaps an update is in order –  cmhughes May 14 '12 at 20:16
    
Looks as if the map-file has not been activated (probably due to the known updmap/udpmap-sys confusion). Try if it works if you add \pdfmapfile{+sansmathaccent.map} to your document. If yes you will have to find out how to get the map-entries permanantly in your pdftex.map. –  Ulrike Fischer May 15 '12 at 7:41
    
Problem fixed. Thanks Ulrike for the big hint. The file typeset fine with \pdfmapfile{+sansmathaccent.map} added. I then ran updmap-sys --enable Map=sansmathaccent.map and still had the problem, but then I discovered a local pdftex.map file, and the problem went away once I removed the local file. Thanks again, everyone. –  Alan Simpson-Vlach May 15 '12 at 12:12
    
@UlrikeFischer Would you make an answer from your comment? –  egreg Jul 26 '12 at 14:38
add comment

1 Answer 1

Looks as if the map-file has not been activated (probably due to the known updmap/udpmap-sys confusion in a multiuser setup). Try if it works if you add \pdfmapfile{+sansmathaccent.map} to your document. If yes you will have to find out how to get the map-entries permanantly in your pdftex.map.

In miktex the easiest way is to call updmap to update the existing local pdftex.map.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.