TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently I tried to reinstall the MathTimePro II fonts in my local texmf directory. I already have Lucida fonts installed which works fine. So I carefully copied all the relevant files/folders to the directories, added the new Map entry in the local updmap.cfg file and executed texhash/mktexlsr and updmap-sys. However my new font does not work, I get the following error:

Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
(./MTPro2 LaTeX test.aux)
map/pdftex/updmap/pdftex.map}] [2] [3] (./MTPro2 LaTeX test.aux)
kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 4+0/600 --dpi
2400 mt2exf gsftopk: fatal: map file `cid-base.map' not found.
mktexpk: don't know how to create bitmap font for mt2exf. mktexpk:
perhaps mt2exf is missing from the map file. kpathsea: Appending font
creation commands to missfont.log.  )

!pdfTeX error: /usr/texbin/pdflatex (file mt2exf): Font mt2exf at 2400
not foun d

==> Fatal error occurred, no output PDF file produced!

It knows where to find mtpro2.sty in the local directory but can't find the fonts which are basically next door!

I have gone through a lot of online remedies but none have helped. I even restored the pdftex to an older version and started all over. The problem seems to be that the pdftex.map file does not have the fonts despite there being a map entry for mtpro2.

PS: I am using TeXShop/TeXLive (2011) on OS X 10.6.

share|improve this question
At first you shouldn't change updmap.cfg directly. In TeXLive you should use updmap-sys --enable Map=XXXX (or updmap --enable Map=XXXX). At second: The path of pdftex.map sounds a bit as if it is a local map generated by updmap (without -sys). Rerun updmap-sys (eventually with the option --verbose and check if it actually change the pdftex.map. – Ulrike Fischer May 15 '12 at 7:14
I added the map entry to my 'local' updmap.cfg, I did use updmap-sys as well and finally the option you recommend does not exist. – Hesam May 15 '12 at 8:03
Did you run updmap-sys and checked if it actually changed the pdftex.map (look e.g. a the file date)? – Ulrike Fischer May 15 '12 at 8:34
Yes everytime I run updmap-sys, pdftex.map gets rewritten (it also says the same in updmap-sys output: "Files generated: ...."). – Hesam May 15 '12 at 8:37
I did't ask if one pdftex.map is generated but if the pdftex.map mentioned in the log gets rewritten. Check the one in Users/hesam/Library/.... – Ulrike Fischer May 15 '12 at 8:46
up vote 15 down vote accepted

The key is here:


You have, is some occasion, run updmap (not updmap-sys) and your TeX system uses the generated pdftex.map sitting in your personal tree.

Remove that file, so that the TeX system will use the global pdftex.map file.

To be on the safe side, after removing the file run from the Terminal the following commands:

sudo tlmgr generate updmap
sudo updmap-sys --enable-map <name>.map

(Change <name> into the correct name of the file in the MTPro distribution.)

In any case, adding the line


before \begin{document} should make pdfTeX able to find the correct map file.

share|improve this answer
I removed that one but it started using the other pdftex.map which is in usr/local/texlive/2011/texmf-var/fonts/map/pdftex/updmap. But this produces the same exact problem. Then I deleted this map file as well and now pdftex does not work anymore. – Hesam May 15 '12 at 9:33
@Hesam Of course, if you delete the global pdftex.map, pdftex won't be able to run. Try following the instructions I added. – egreg May 15 '12 at 9:41
In case of "Unknown option: enable-map", see tex.stackexchange.com/questions/51704/… for example with updmap-sys --enable Map=_font_.map – sdaau Oct 11 '14 at 22:39

As recommended by @jon in this post purge latex or all the version of latex entirely from your system and install again that did the job for me. After spending some time trying in vain for hours to get latex use the right updmap file, reinstall latex completely.

If you face the same problem I suggest this answer which guide you towards completely removing latex from your system.. Make sure to search and delete any file related to /texlive/year/ before installing latex again.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.