Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

The title says it. The instructions in http://wiki.lyx.org/LyX/SyncTeX no longer works for forward search. I think the PDF command: okular --unique "file:$$o#src:$$n $$t" is no longer working for new TeX software. Inverse search is workable though.

share|improve this question
    
how did you get the inverse search to work.. i can't even get that.. using windows 7 lyx 2.0.5 –  Alex Dec 14 '12 at 5:37
    
I am not using windows. Suggest that you start a new question to have it answered. –  ggg Dec 21 '12 at 3:05
add comment

1 Answer

It works in my machine (openSUSE) with the following options. In LyX, Tools > Preferences > Output > General > PDF command under Forward search:

okular --unique "file:$$o#src:$$n $$f"

or

okular --unique "$$o#src:$$n $$f"

Both worked for me. Hope this solves your problem. And $$f option only works with LyX 2.0.5+.

share|improve this answer
    
I just edited the LyX wiki as well. –  joon Jan 17 '13 at 17:07
    
In LyX "Document settings... > Output" the default for "Custom Macro" seems to be \usepackage[active]{srcltx} rather than \synctex=-1 as stated in the LyX wiki. For LyX 2.0.5.1 with Okular 0.14.3 (on openSUSE), it seems necessary to set "Custom Macro" to \synctex=-1. Then forward and inverse search are working. –  e-birk Apr 6 '13 at 23:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.