Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

When I build my document, several weird characters appear. Take a look at the picture below:

Several problems

The most strange thing, is that exactly the same tex file compiles fine on an other computer of mine. I am using TexLive 2011, the same version as on my other computer. A fresh install of TexLive did not solve the problem.

Does any one have a clue about what could be causing this problem? I suspect there is something wrong with my TexLive distribution, not the document. (It also happens for all of my documents, but that could be because they use mostly the same packages (among others fontspec, xltxtra, polyglossia, url and hyperref).

share|improve this question
3  
Normally this happens when you have two versions of the font. xetex then uses the one and the driver xdvidpfmx the other and this results in glyph confusion. Put \XeTeXtracingfonts=1 in your document and compile on the command line with xelatex --output-driver="xdvipdfmx -vv". Then compare the font pathes in the log with the output of xdvipdfmx. –  Ulrike Fischer May 21 '12 at 9:08
    
Unfortunately, XeLaTeX crashes when I try that. –  Ruud v A May 21 '12 at 10:46
    
It shouldn't but as you didn't give some informations (like error messages) I can't tell why it doesn't work for you. Btw: There is no space in the option the -vv and naturally you should add the name of document at the end. –  Ulrike Fischer May 21 '12 at 11:20
    
The program simply crashes without any error message. (This usually means an access violation or stack overflow, etc.) You were right about the font. I removed the entire font family from my computer and re-installed it, and now it works fine. Thank you very much! –  Ruud v A May 21 '12 at 14:21
    
@UlrikeFischer You should turn your comment into an answer. –  Alan Munn May 21 '12 at 16:07
add comment

1 Answer

up vote 1 down vote accepted

Normally this happens when you have two versions of the font. xetex then uses the one and the driver xdvipdfmx the other and this results in glyph confusion. Put \XeTeXtracingfonts=1 in your document and compile on the command line with xelatex --output-driver="xdvipdfmx -vv" file. Then compare the font pathes in the log with the output of xdvipdfmx.

share|improve this answer
    
BTW, in TL2012 this should be fixed. –  Khaled Hosny May 21 '12 at 18:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.