Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to add citations to a technical report using ~\cite, so that the result would be text[1]. But instead I get text [1] with a space between the citation and the text. I am using \usepackage{cite}. How do I remove the space?

share|improve this question
1  
Why would you remove the space? –  egreg May 21 '12 at 14:46
    
Requirement of the report. –  user1049697 May 21 '12 at 14:55
5  
I always keep forgetting that crazy requirements are so frequent. :( –  egreg May 21 '12 at 14:56
add comment

2 Answers

To remove the space, remove the tilde ~ and just use text\cite{...}. This is, however, a rather unusual use of \cite.

In short, when you type ~ (also called a "tie") it's the same as typing a space, except that TeX won't break a line at this space. For a reference on the usage of ~ with/without citation, see What is the difference in citing/referencing with or without tilde?

share|improve this answer
    
Removing the tilde doesn't remove the space. –  user1049697 May 21 '12 at 14:55
7  
@user1049697: Did you use ...text \cite{..} or ...text\cite{..}? If neither of these work, then you should post a minimal example as part of your question showing exactly what you're doing. –  Werner May 21 '12 at 14:57
add comment

You can add an option for the cite package:

\usepackage[noadjust]{cite}

to avoid the unwanted space .

share|improve this answer
1  
Welcome to TeX.SX! You can have a look on our starter guide to familiarize yourself further with our format. –  Claudio Fiandrino Jun 16 '13 at 16:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.