Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to use the memoir class \medievalpage command and cannot get it to work. Here is my effort:

\documentclass[12pt]{memoir}
\usepackage{lipsum}
\medievalpage
\checkandfixthelayout

\begin{document}
\lipsum
\end{document}  
share|improve this question
    
Welcome to TeX.sx! A tip: If you indent lines by 4 spaces, they'll be marked as a code sample. You can also highlight the code and click the "code" button (with "{}" on it). –  Marco Daniel May 21 '12 at 18:12
    
Your example seems to do what it is supposed to do. What exactly do you mean with "cannot get it to work"? –  lockstep May 21 '12 at 18:15
    
I get a single page with a block text area, rather than two columns of text. –  mokane May 21 '12 at 18:20
    
\medievaltext only sets the page margins, but doesn't switch to twocolumn mode. Try \documentclass[12pt,twocolumn]{memoir}. –  lockstep May 21 '12 at 18:22
    
Ah, OK. Medieval texts always seemed to be in two columns, I thought it automatically provided that functionality. –  mokane May 21 '12 at 18:28

2 Answers 2

The \medievalpage, sets the page geometry to comply with classic page proportions. To get it to two column use:

  \documentclass[twoside,twocolumn]{memoir}
  \medievalpage
  \checkandfixthelayout

This should give a page similar to the image below:

enter image description here

share|improve this answer
    
How do you put all those lines and frames? Is there a package for that? –  Harish Kumar May 21 '12 at 23:34
2  
@HarishKumar I am busy writing it:) –  Yiannis Lazarides May 22 '12 at 2:43
    
That sounds exciting. When can we expect to get it? Soon? –  Harish Kumar May 22 '12 at 22:46
    
@HarishKumar Possibly this weekend I will put it up at Git. –  Yiannis Lazarides May 23 '12 at 0:25
    
I am eagerly waiting to use it. Pl. notify it. –  Harish Kumar May 23 '12 at 0:26

\medievalpage only sets the page margins, but doesn't switch to twocolumn mode -- for the latter, you have to add the twocolumn class option. Additionally, I suggest to enlarge the space between columns (LaTeX's default value of 10pt is too small IMO) and to load the microtype package -- its protrusion and font expansion features result in better line breaks for small columns.

\documentclass[12pt,twocolumn]{memoir}

\medievalpage
\checkandfixthelayout

\setlength{\columnsep}{20pt}

\usepackage{microtype}

\usepackage{lipsum}

\begin{document}

\lipsum

\end{document}  
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.