Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

The journal I am submitting to requires the bibliography be listed in the order cited in the text. How can I do this with ReVTeX?

I have tried different journal styles but can't get it to work. If I try to override the natbib settings there is an error. I have tried the \bibliographystyle settings as well but those seem to be ignored.

share|improve this question
    
A simple test using revtex4-1 and \bibliographystyle{unsrtnat} worked as expected. Can you please add to your question a minimal working example showing the settings relevant to this problem? –  Gonzalo Medina May 22 '12 at 16:00
    
Thank you for the response: my settings are as follows: \documentclass[superscriptaddress,onecolumn,reprint]{revtex4-1} \usepackage{array} \usepackage{amsmath} \usepackage{graphicx} \usepackage{verbatim} \usepackage{color} \usepackage{subfigure} \usepackage{epspdfconversion} \usepackage{hyperref} I am not using a bib file as it is not allowed. I have the bibitems taken from the bbl file. I tried \bibliographystyle{unsrtnat} but the articles are still listed in alphabetical order by author's last name. I need them in the order they are cited in the text. –  user14860 May 23 '12 at 5:17
add comment

2 Answers

The revtex4-1 document class automatically loads the natbib package with the option sort&compress. For numerical citation methods, this ensures that an otherwise wild-looking list such as [4,2,8,3] will be rendered as [2-4,8]; for author-year citation methods, this option is equivalent to (simple) sorting by year (and, if necessary, within year by affixing a, b, etc).

If the journal you're submitting your paper to does not want the bibliography to be sorted alphabetically by authors' last names, it should also specify which bibliography style file should be used. If the journal for some reason has failed to do so, you should select a style file -- unsrtnat.bst would be a good candidate, given that you're likely using natbib's citation commands -- that does not perform any sorting of the bib entries. Incidentally, after selecting a new style file, it may be necessary to wipe out the auxiliary files and perform the latex-bibtex-latex-latex sequence from scratch.

A separate issue: have you been able to determine which basic citation method is required by the journal: numeric or authoryear? If it's the former, you should include the instruction

\setcitestyle{numbers}

in the preamble. If it's the latter, you may want to play it safe by including the instruction

\setcitestyle{authoryear}

in the preamble. This is actually the default when natbib is set up. However, it may be the case that some of the other files you're loading override this default, in which case it may be necessary to restore the default setting explicitly.

share|improve this answer
add comment

I was able to resolve the issue because I made what appears to be a basic LaTeX error that I did not accurately describe above.

The journal I am subbmitting to does not allow bib files, therefore the use of \begin{thebibliography} with \bibitem's is required. It seems that the order of bibitem's is taken directly.

When I replaced these items with a bib file, the correct numbering was restored. I then copy/pasted the newly ordered bibitem's from the bbl file and the order was maintained. Thanks to everyone who commented/answered my question.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.