Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have problem in which I am using \autocite within TexMakerX and it is being highlighted as an unrecognized command yet, when I use the LaTeX to PDF command, it seems to work. There is no error when I run LaTeX on the document.

In addition, I would like the citation to include the author's name in the footnote, currently it is just the title, publisher, etc.

My document looks like this

\documentclass{article}
\usepackage[notes]{biblatex-chicago}
\bibliography{bibliography}
\begin{document}

Hello World!\autocite{clare2}

\end{document}
share|improve this question
1  
TeXMakerX is a front-end for editing (La)TeX files. As such, what TeXMakerX (or any other editor) highlights as 'known' is not directly linked to what LaTeX itself will recognise. –  Joseph Wright May 22 '12 at 18:35
    
Ok, thank a lot for your help. I am also using Miktext. Is there a package I could add so that it would "know"? –  Mike Stumpf May 22 '12 at 19:42

1 Answer 1

up vote 3 down vote accepted

First, TexmakerX has changed name to TeXstudio, so if you're running TexmakerX you probably have an old version. I would upgrade.

The commands recognized by TeXstudio are defined in .cwl files, and your version doesn't have such a file for biblatex. The current stable version doesn't have this either, but the latest build from SVN does. You have three options:

  1. Get the biblatex.cwl file from SourceForge and place it in the correct folder, as described in section 1.4 of the TeXstudio manual. The folder is found in the AppData folder in your user folder, e.g. c:\Documents and Settings\User\AppData\Roaming\texstudio.

    (A tip: In Windows 7, and at least some older versions of Windows, %appdata% is a kind of shortcut to get to the AppData (or AppData/Roaming). Just type %appdata% in the address bar in Explorer or the search bar on the start menu, and hit enter.)

  2. Install the latest SVN-version of TeXstudio: direct link to download on SourceForge. As this isn't really released yet, I suppose there may be bugs that aren't fixed.

  3. Wait for the next stable version (2.4).

share|improve this answer
    
Success! Thank you very much. It was very clear what to do with your help in addition to the user's manual. –  Mike Stumpf May 23 '12 at 10:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.