Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to change the font size of the references using the shrink of the frame argument. However, if I run this code:

\documentclass{beamer}

\usepackage[american]{babel}
\usepackage[utf8]{inputenc}
\usepackage{csquotes}
\usepackage[style=apa, backend=biber,doi,url]{biblatex}
\DeclareLanguageMapping{american}{american-apa}

\begin{filecontents}{literature.bib}
@article{foobar,
  Author = {An Author},
  Journal = {A Journal},
  Pages = {1--2},
  Title = {Some title},
  Volume = {1},
  Year = {1900}
}

\end{filecontents}
\addbibresource{literature.bib}

\begin{document}

\frame{
  \textcite{foobar}
}

\frame[shrink=50]{
  \frametitle{References}
  \printbibliography
}

\end{document}

I get the following error:

! Arithmetic overflow.
\beamer@shrinkframebox ...\@tempdimc by\@tempcnta 
                                                  \relax \ifdim \@tempdimc >...
l.32 }

? 
! Emergency stop.
\beamer@shrinkframebox ...\@tempdimc by\@tempcnta 
                                                  \relax \ifdim \@tempdimc >...
l.32 }

If I remove the shrink argument it works.

I'm using TexLive 2011 on Debian Squeeze and I updated all my packages ;).

share|improve this question
    
Test with \frame[shrink=50,fragile], this often helps if you are doing complex stuff on your frame ;-) –  schlamar May 24 '12 at 11:51
    
Thanks for your help! With \frame[shrink=50,fragile] I get Runaway argument? ! File ended while scanning use of \next. –  deboerk May 24 '12 at 12:53
    
What happens if you change directly the font size, for example with \tiny? –  schlamar May 24 '12 at 13:04
    
The font size of the references stays the same. –  deboerk May 24 '12 at 13:22
3  
Maybe \renewcommand*{\bibfont}{\scriptsize} will help. –  André May 24 '12 at 17:18

2 Answers 2

up vote 10 down vote accepted

I think \renewcommand*{\bibfont}{\scriptsize} will help! ;)

share|improve this answer

I tried André's answer with no success. I found a work-around, if you need a quick solution:

  1. Compile your beamer document including the bibliography (correct settings of citing/formatting style etc.).

  2. open the *.bbl file and copy all its contents (\begin{thebibliography} ...\end{thebibliography}).

  3. Paste it over the \bibliograpy{yourbibfile} command.

  4. put a \small tag after \begin{thebibliography} for a smaller fontsize for your references!

As I said, its a quick way, if you don't want to fuss around. The downside being its complete absence of reactiveness to changes (\...cite commands) in your document.

share|improve this answer
1  
Welcome to TeX.SX! I've taken the liberty of editing your answer, to keep it in line with the site's style. –  egreg Jul 9 '13 at 17:03
    
Welcome to TeX.SX! You can have a look on our starter guide to familiarize yourself further with our format. –  Claudio Fiandrino Jul 9 '13 at 17:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.