Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I could not get the expected result when compiling the following with latex-dvips-ps2pdf. The unexpected result is just a single blank page with a page number 1. :-)

\documentclass{article}
\usepackage{graphicx}

\begin{document}

\includegraphics{example-image-a}

\end{document}

Is example-image-a compatible with latex (i.e. DVI mode)? Is there an EPS version for that image?

Loading mwe package did not help as well.

Log from latex.exe

This is pdfTeX, Version 3.1415926-2.3-1.40.12 (MiKTeX 2.9)
entering extended mode
(F:\test.tex
LaTeX2e <2011/06/27>
Babel <v3.8m> and hyphenation patterns for english, afrikaans, ancientgreek, ar
abic, armenian, assamese, basque, bengali, bokmal, bulgarian, catalan, coptic, 
croatian, czech, danish, dutch, esperanto, estonian, farsi, finnish, french, ga
lician, german, german-x-2009-06-19, greek, gujarati, hindi, hungarian, iceland
ic, indonesian, interlingua, irish, italian, kannada, kurmanji, lao, latin, lat
vian, lithuanian, malayalam, marathi, mongolian, mongolianlmc, monogreek, ngerm
an, ngerman-x-2009-06-19, nynorsk, oriya, panjabi, pinyin, polish, portuguese, 
romanian, russian, sanskrit, serbian, slovak, slovenian, spanish, swedish, swis
sgerman, tamil, telugu, turkish, turkmen, ukenglish, ukrainian, uppersorbian, u
senglishmax, welsh, loaded.
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\base\article.cls"
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\base\size10.clo"))
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\mwe\mwe.sty"
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\graphics\graphicx.sty"
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\graphics\keyval.sty")
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\graphics\graphics.sty"
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\graphics\trig.sty")
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\00miktex\graphics.cfg")
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\graphics\dvips.def")))
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\lipsum\lipsum.sty")
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\blindtext\blindtext.sty"
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\tools\xspace.sty"))) (F:\test.aux
) <example-image-a.eps> [1] (F:\test.aux) )
Output written on test.dvi (1 page, 284 bytes).
Transcript written on test.log.
share|improve this question
    
Do you have the mwe package installed? –  Joseph Wright May 26 '12 at 13:58
    
What is the unexpected result you are getting? –  Martin Scharrer May 26 '12 at 14:01
    
Well, why do you not write that in the first place! –  Martin Scharrer May 26 '12 at 14:03
    
@Forgiver: It's not clear what exactly happens, e.g. if you get an error or not etc. and this is important to figure out what exactly goes wrong. Sentences like "it doesn't work" or "not the expected result" are not helpful. Your log file clearly shows that the EPS file is found and used. The manual clearly states that EPS versions are provided. It works fine for me in DVI and PDF mode. What file are you viewing? The DVI, EPS or PDF file? Note that some DVI viewer might not show included EPS files. –  Martin Scharrer May 26 '12 at 15:04
    
Locate the example-image-a.eps file (e.g. kpsewhich example-image-a.eps or use the search tool of your OS) and check if it is OK. –  Martin Scharrer May 26 '12 at 15:40

1 Answer 1

up vote 4 down vote accepted

There is an example-image-a.eps provided by mwe as well as EPS versions for the other images, as stated in the manual.

However, there seems to be an issue with these EPS files as Ulrike pointed out. They seem not include the proper headers which make a PS file an EPS file. I, as author of mwe, will rebuild the EPS files and upload them as soon I find time. I tested the existing versions with TeX Live 2011 under Ubuntu Linux where they worked fine, but other tools might be more picky about the EPS headers.

share|improve this answer
4  
I can confirm that the eps doesn't work. The correct place is reserved but the image doesn't show up after latex + dvips in gsview. An inspection of the some of the eps-files shows that they are no real eps (they start with %!PS-Adobe-2.0). Everything works fine if I convert them with the epswrite device to eps. Then they start with %!PS-Adobe-3.0 EPSF-3.0 and show up correctly. I would say you forgot the -E switch when calling dvips. –  Ulrike Fischer May 26 '12 at 16:37
    
Thanks @Ulrike, this helps a lot. I tested the EPS only with TeX Live were they worked and trusted that they are fine. Indeed they might be "normal" PS files. I will change my build work-flow and upload a corrected version. –  Martin Scharrer May 26 '12 at 16:40
1  
@Forgiver: I updated the answer. Please note that package bugs are actually not on-topic IMHO, but should be reported directly to the package author. Until Ulrike's comment I thought it's rather an installation or similar issue on your side. –  Martin Scharrer May 26 '12 at 16:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.