Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have such preamble:

\documentclass[bachelor, subf]{gost732}

\usepackage[a4paper,includefoot,
            left=3.5cm, right=1cm,
            top=2cm, bottom=2cm,
            headsep=1cm, footskip=1cm]{geometry}

\usepackage[T2A]{fontenc}
\usepackage[cp1251]{inputenc}
\usepackage[english]{babel}
\setcounter{tocdepth}{2}
\usepackage{tikz}
\usepackage{tabularx}
\usepackage{graphics}
\usepackage{afterpage}
\usepackage{pscyr}
\usepackage[14pt]{extsizes}
\usepackage[perpage,symbol]{footmisc}
\binoppenalty=10000
\relpenalty=10000

\renewcommand{\thechapterfont}{\normalsize\bfseries}
\renewcommand{\prethechapter}{} 
\renewcommand{\postthechapter}{.~}
\renewcommand{\appendixfont}{\normalsize\bfseries}
\renewcommand{\chapterfont}{\normalsize\bfseries}
\renewcommand{\sectionfont}{\normalsize\bfseries}
\renewcommand{\subsectionfont}{\normalsize\bfseries}
\renewcommand{\subsubsectionfont}{\normalsize\bfseries}
\renewcommand{\theappendixalign}{\hfill}
\renewcommand{\theappendix}{\arabic{chapter}} 
\renewcommand{\pretheappendix}{\protect{Attachment}~} 
\renewcommand{\tocpretheappendix}{\protect{Attachment}~}
\renewcommand{\introname}{Introduction}
\renewcommand{\sectionindent}{1cm}
\renewcommand{\subsectionindent}{1cm}
\renewcommand{\aftersection}{6pt plus .1pt}
\renewcommand{\aftersubsection}{3pt plus .1pt}
\renewcommand{\conclusionname}{Conclusion}
\ifpdf\usepackage{epstopdf}\fi
\def\headfont{\small}
\pagestyle{headcenter}
\chapterpagestyle{empty}
\makeatletter
\renewcommand{\@biblabel}[1]{#1.\hfil}
\makeatother
\hyphenpenalty=10000

Text is going out of bounds. I set the right border to 1 cm, but when I prohibited the hyphenation of all words, the border increased and the text began to go out of bounds:

How to fix this problem? Please, help.

enter image description here

share|improve this question
2  
You should find in the log file what geometry is doing; I suspect some interaction with the class. If you're using a specialized class, you shouldn't tamper with the page parameters. Of course, disabling hyphenation will make it difficult for TeX to produce good paragraphs, particularly at 14pt size. Don't disable hyphenation and don't use font so big, unless the document is for sight impaired people. –  egreg May 29 '12 at 10:48
2  
If you really must suppress hyphenation, you may find it better to set the text raggedright, –  Brent.Longborough May 29 '12 at 12:31
    
\usepackage{microtype} might also help to mitigate some of your overfull hboxes. But basically when you suppress hyphenation, you're making TeX's job of fitting everything neatly in fixed-width lines much much harder. You can use the dreaded \sloppy, too. Overfull hboxes will be replaced by too much whitespace between words but when you don't want hyphenation and you don't want left-justification, you'll have to choose your poison. –  Christian May 29 '12 at 16:18
    
\usepackage{microtype} solved the problem, thanks –  user565447 May 29 '12 at 17:32
    
@user565447 good to hear that that helped already. I turned my comment into an answer. –  Christian May 30 '12 at 14:01

1 Answer 1

up vote 2 down vote accepted

microtype can help to mitigate the problem and if all else fails, \sloppy will convert ugly overfull hboxes to ugly oversized interword spacing.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.