Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Some lines of my document become very very "stretched". Here is my preamble:

\documentclass[bachelor, subf]{gost732}

\usepackage[a4paper,includefoot,
            left=3.5cm, right=1cm,
            top=2cm, bottom=2cm,
            headsep=1cm, footskip=1cm]{geometry}

\usepackage[T2A]{fontenc}
\usepackage[cp1251]{inputenc}
\usepackage[english]{babel}
\setcounter{tocdepth}{2}
\usepackage{tikz}
\usepackage{tabularx}
\usepackage{graphics}
\usepackage{afterpage}
\usepackage{pscyr}
\usepackage[14pt]{extsizes}
\usepackage[perpage,symbol]{footmisc}
\usepackage{enumitem}
\binoppenalty=10000
\relpenalty=10000

\renewcommand{\labelenumii}{\arabic{enumi}.\arabic{enumii}.} 
\renewcommand{\thechapterfont}{\normalsize\bfseries}
\renewcommand{\prethechapter}{}
\renewcommand{\postthechapter}{.~}
\renewcommand{\appendixfont}{\normalsize\bfseries}
\renewcommand{\chapterfont}{\normalsize\bfseries}
\renewcommand{\sectionfont}{\normalsize\bfseries}
\renewcommand{\subsectionfont}{\normalsize\bfseries}
\renewcommand{\subsubsectionfont}{\normalsize\bfseries}
\renewcommand{\theappendixalign}{\hfill}
\renewcommand{\theappendix}{\arabic{chapter}} 
\renewcommand{\pretheappendix}{\protect{Attachment}~} 
\renewcommand{\tocpretheappendix}{\protect{Attachment}~}
\renewcommand{\introname}{Introduction}
\renewcommand{\sectionindent}{1cm}
\renewcommand{\subsectionindent}{1cm}
\renewcommand{\aftersection}{6pt plus .1pt}
\renewcommand{\aftersubsection}{3pt plus .1pt}
\renewcommand{\conclusionname}{Conclusion}
\ifpdf\usepackage{epstopdf}\fi
\def\headfont{\small}
\pagestyle{headcenter}
\chapterpagestyle{empty}
\makeatletter
\renewcommand{\@biblabel}[1]{#1.\hfil}
\makeatother
\hyphenpenalty=10000

Here is an example. I have noticed that the line becomes very "stretched" when there is a new indent after it. Why are they so "stretched"?

enter image description here

share|improve this question
10  
If you disable hyphenation but still ask for text to be justified on both left and right then stretching space is the only option. Perhaps you want \raggedright ? –  David Carlisle May 29 '12 at 12:23
4  
Please, add the text of the offending paragraph. However, as I already explained, inhibiting hyphenation with a reduced line width and big font size is not a good idea. –  egreg May 29 '12 at 12:24
    
You seem to enclose "The complement graph" into some box that disallows line breaks. –  yo' May 29 '12 at 12:37
    
"The complement graph" probably starts a new paragraph, given the indentation difference between it and the following lines. –  Mike Renfro May 29 '12 at 14:14
3  
It seems like you are using \linebreak to end your paragraphs; if this is the case, remove those \linebreaks commands and leave a blank line, or use \par to end paragraphs. –  Gonzalo Medina May 29 '12 at 14:36

1 Answer 1

up vote 7 down vote accepted

It seems like you are using \linebreak to end your paragraphs; if this is the case, remove those \linebreak commands and leave a blank line, or use \par to end paragraphs.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.