Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've a problem with my table of contents in LaTeX. For some reason it uses the entire page area. The problem is illustrated here:

http://twpmedia.se/kilten/files/tableofcontent.pdf

Anyone knows a solution to this, so that the second content page uses the same spacing as the first?

Maybe I should point out that I'm using

\usepackage{parskip}
share|improve this question
1  
Welcome to TeX.sx! Please add a minimal working example (MWE) that illustrates your problem. –  David Carlisle May 31 '12 at 9:42
    
It looks like you're using a KoMaScript class (scrbook, perhaps), which has its own method for setting the parskip. –  egreg May 31 '12 at 10:29

3 Answers 3

up vote 0 down vote accepted

Had the same problem with the second page of toc getting stretched out over the page. What solved it for me was simply adding \newpage:

\tableofcontents

\newpage
share|improve this answer

Maybe you had some \pagebreak command after \tableofcontents? That would explain the behavior with the scrbook class. If you need to force a page break because you have something like a dedication page, use \cleardoublepage.

It looks like you're using the scrbook class for your document. In this case you shouldn't use the parskip package, but add to the class the corresponding option. Typesetting this mock document doesn't show your problem.

\documentclass[a4paper,parskip=full]{scrbook}
\usepackage{blindtext}

\begin{document}
\frontmatter
\tableofcontents
\cleardoublepage

\thispagestyle{empty}
\vspace*{\stretch{1}}
\begin{flushright}
Dedicated to my cat
\end{flushright}
\vspace*{\stretch{2}}
\cleardoublepage

\mainmatter
\Blinddocument
\Blinddocument
\Blinddocument
\Blinddocument
\Blinddocument
\Blinddocument
\Blinddocument
\end{document}

The same (without \frontmatter and \mainmatter) if you're using scrreprt instead.

share|improve this answer

In documents with the layout "twoside" (like yours) KOMAscript uses \flushbottom. Maybe you can try:

{% Begin a group
\raggedbottom%
\tableofcontents
}%end of the group

But that's just a long shot in the dark, maybe you should provide your preamble here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.