Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I want to setup latex environment on Ubuntu 12.04 64bit Machine. As I am making a backup system for Windows 7 machine.

I have installed the latest version of Texmaker 3.3.4.

Now I want to know which latex distribution to install for making PDF files.

I seen few like XeLaTeX, TeX Live etc. Can you suggest the LaTeX distribution for Ubuntu which is very well maintained and up to date? I have used MiKTeX 2.9 for Windows and found it very good.

So In a nutshell I am looking for an Ubuntu (Linux) alternative to MiKTeX.

share|improve this question
2  
The easiest thing to do is install from the Ubuntu repositories: sudo apt-get install texlive-full ('smaller' possibilities also exist). But if you want a more current version, there is TeX Live 2011 ... but if you want or need to be closer to the cutting edge, wait a bit for TL 2012. I'm happy manually updating my old TL 2009 (from apt) by getting what I need from CTAN, but many here will encourage you to install TL straight from the website. It really depends on what you need. –  jon Jun 8 '12 at 15:59
1  
There is only one: TeX Live. It is recommended not to get it from Ubuntu as it is very old and unmaintained. It is better to install the version directly from TUG (tug.org/texlive) which usually include an updating tool (similar to the MikTeX package manager) such that you can get updated directly from your local CTAN mirror. There should be guides here (somewhere) explaining how to install TUG TL on Ubuntu. Though the current TUG TL is frozen in preparation for TL 2012. –  daleif Jun 8 '12 at 16:04
    
I would not recommend manually updating a TL 2009, especially if one does not know what one is doing. Just getting the siunitx dependencies to work, may confuse a lot of people. –  daleif Jun 8 '12 at 16:06
    
@daelif -- As I said, it depends on what you need; I have no doubt that most would choose the version from TUG. But what is the best solution when TL 2011 is frozen, and TL 2012 is not yet out? My understanding is that when '12 comes out, you have install that on top of, or in parallel to, '11. Or has that changed? –  jon Jun 8 '12 at 16:58
    
Just to share my experience: MikTex is actually open source and you can install it in Ubuntu - miktex.org/unx/about - but it's buggy as hell (not sure why tho). I'm also full into Linux but I got a VM running to use MikTex with Windows 7 because it's so comfortable... –  vertoe Jun 8 '12 at 17:02
add comment

1 Answer

up vote 1 down vote accepted

Use the well maintained and up to date cross platform Latex distribution Texlive 2011 for Ubuntu. Don't try installing the Texlive 2009 from Ubuntu Repositories as they are pretty old. If you prefer an easy install then go with texlive 2009 from Ubuntu Repositories. Some of the packages would be outdated. Check the outdated packages using http://www.ctan.org/tex-archive/macros/latex/contrib/nag (Nag pakcage)

If really want to try out texlive 2011 follow the links Install using the links given here. Unfortunately there are in french. http://www.xm1math.net/doculatex/index.html#install

Official Documentation from TUG http://www.tug.org/texlive/doc/texlive-en/texlive-en.html

If you love testing the new texlive 2012, you can proceed with that also. http://www.tug.org/texlive/pretest.html

share|improve this answer
    
nag will not catch all the outdated packages. It will not say, for instance, that TL2009's version of hyperref is out of date. It has a different focus. –  jon Jun 18 '12 at 16:51
    
nag inaddition with l2tabu ctan.org/pkg/l2tabu will help. –  texenthusiast Jun 18 '12 at 16:57
    
Yes, just with a different 'problem' than the ones that comes from installing from the Debian/etc. repositories (which is how I use *tex, though I have manually updated the packages that I use regularly). The focus with the two packages you mention are to catch obsolete commands (e.g., from 2.09) or obsolete packages --- not out of date ones. –  jon Jun 18 '12 at 21:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.