Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

In the code below, the equation within the itemize environment is too wide for the page, but I don't get an overfull hbox warning (which I find annoying because it's sometimes useful to know exactly how wide an overfull hbox is).

I'd like to know how to get the compiler to produce the 'usual' overfull hbox warning in these circumstances. I'm also curious as to why this happens. Any help will be much appreciated.

\documentclass[a4paper,12pt,draft]{article}  
\usepackage{amsmath}  
%  
\begin{document}  
The text that appears here shows the complete page width.
No doubt the long equation displays ok now.  
\begin{align}  
A + Bz + Cz^2 + Dz^3 + Ez^4 + Fz^5 + G z^6 + H z^7 + I z^8 + J z^9 + K z^{10} = 0.  
\end{align}  
%  
\begin{itemize}  
\item The text that appears here shows the width within the list.
The equation below will overspill the right
margin, without producing a warning.  
\begin{align}  
A + Bz + Cz^2 + Dz^3 + Ez^4 + Fz^5 + G z^6 + H z^7 + I z^8 + J z^9 + K z^{10} = 0.  
\end{align}  
\end{itemize}  
\end{document}
share|improve this question
1  
It is likely a bug. Please follow the instructions in the README file ctan.org/tex-archive/macros/latex/required/amslatex/math and file a bug at tech-support@ams.org –  Willie Wong Nov 24 '10 at 18:28

2 Answers 2

up vote 3 down vote accepted

It certainly looks like a bug. Firstly, you can have a better display if you default to LaTeX as shown below. AmsTeX now and then uses \vfuzz as a scratch register so I thought I will try it out redefining it within the environment, but without much success (it is quite likely it is set at a high value within a macro).

\documentclass[a4paper,12pt,draft]{article}  
\usepackage{amsmath}  
%  
\begin{document}  

\overfullrule=10pt
The text that appears here shows the complete page widthened.
No doubt the long equation displays ok now.  
\begin{align}  
A + Bz + Cz^2 + Dz^3 + Ez^4 + Fz^5 + G z^6 + H z^7 + I z^8 + J z^9 + K z^{100000} = 0.  
\end{align}  
%  
\begin{itemize}  
\item The text that appears here shows the width within the list.
The equation below will overspill the right
margin, without producing a warning.  
\begin{align} 
\vfuzz=0pt 
A + Bz + Cz^2 + Dz^3 + Ez^4 + Fz^5 + G z^6 + H z^7 + I z^8 + J z^9 + K z^{1000000000} = 0  
\end{align} 


\item The text that appears here shows the width within the list.
The equation below will overspill the right
margin, without producing a warning. 

\[A + Bz + Cz^2 + Dz^3 + Ez^4 + Fz^5 + G z^6 + H z^7 + I z^8 + J z^9 + K z^{1000000000} = 0 \]

\end{itemize}  
\end{document}
share|improve this answer
1  
Thanks. I've submitted a bug report. –  Ian Thompson Nov 25 '10 at 14:16

For info, here is the email that I received from AMS technical support today.

ian,
there's no question that this is a bug, but there is a question about what sort of bug it is.

if you change the document class line to

\documentclass[11pt,draft]{amsart}

you will see that the effect is quite different. in particular, the aligned formula is centered on the page width in both instances -- it was a design feature to not center multi-line displays on narrowed list environments, but this appears to be overridden in the article class. centering on narrower text has been requested, and this will be considered in the next upgrade, which is expected to be scheduled sometime early in 2011; if the request is accepted, this will probably be made an option, to avoid affecting existing documents.

if you replace just "article" by "amsart", you will see that the overfull lines are indeed reported. so this too is specific to the article class, not the ams classes. however, since amsmath is used extensively with non-ams classes, compatibilty is important.

i have added this to the list of problems to be addressed with the next upgrade.

thank you for reporting it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.