Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have created chapter by

\chapter{"one"}

I want this to be visible in my table of contents but when I do \tableofcontents. I cannot see them. Can anyone tell me how to include chapters in table of contents? I am using latex in ubuntu 12.04. For instance if \chapter{"one"} is in page 20 and is the third chapter. Then in table of contents I should see 3. One 20 Something like this.

Edited version

Here is a small sample latex script. I have used acm template:

\documentclass[prodmode,acmtap]{acmlarge}

\acmArticle{n}

\usepackage[ruled]{algorithm2e}
\SetAlFnt{\algofont}
\SetAlCapFnt{\algofont}
\SetAlCapNameFnt{\algofont}
\SetAlCapHSkip{0pt}
\IncMargin{-\parindent}
\renewcommand{\algorithmcfname}{ALGORITHM}

% Title portion
\title{Sample text}
\author{Sadiksha}

\begin{document}

\maketitle
\pagebreak

\tableofcontents
\pagebreak

\chapter{ABC}
this is a content

\end{document}

I can see a title page, table of contents with no ABC in it, just Contents.

The link to the template is: http://www.acm.org/publications/latex_style/acm-large-v1-3.zip

share|improve this question

migrated from stackoverflow.com Jun 10 '12 at 21:39

This question came from our site for professional and enthusiast programmers.

4  
Tables of contents in LaTeX need several (typically 2) compilation passes to reflect changes properly. Have you made sure you ran the latex command at least twice? Also, could you make a small, standalone example that reproduces the problem, and include it in your question? –  Alexis Pigeon Jun 10 '12 at 20:49
    
yes I did run it twice but with no result. Actually I am using acm template. –  Sadiksha Gautam Jun 10 '12 at 21:04
5  
Please add to your question a minimal and complete document showing the relevant settings. –  Gonzalo Medina Jun 10 '12 at 21:59
    
Your document class is unknown. Please use a standard one or provide a link to this document class. –  Marco Daniel Jun 11 '12 at 9:53

1 Answer 1

up vote 4 down vote accepted

The largest sectional unit supported by the acmlarge document class is \section. For some reason, \chapter is defined to \relax, so using it doesn't cause an error, but it doesn't create a chapter either.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.