Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.
\documentclass{article}

\usepackage{xltxtra}
\usepackage{skak}

\setmainfont{Arial}
\setmonofont{Courier New}

\usepackage{polyglossia}
\setmainlanguage{english}

\catcode"2654=\active
\catcode"2655=\active
\catcode"2656=\active
\catcode"2657=\active
\catcode"2658=\active
\catcode"2659=\active

\def\K{\fontspec{FigurineCB AriesSP}\char"00A2}

\let♔\K
\let♕\symqueen
\let♖\symrook
\let♗\symbishop
\let♘\symknight
\let♙\sympawn

\begin{document}


♔♕♖♗♘♙

♔♕♖♗♘♙

\end{document}

Why does xskak produce an incompatibility error when using XeLaTeX?

Error: `\Finv already defined \{mathord}{AMSb}{"60}'   

skak works fine.

share|improve this question
    
Welcome to TeX.sx! A tip: If you indent lines by 4 spaces, they'll be marked as a code sample. You can also highlight the code and click the "code" button (with "{}" on it). –  Joseph Wright Jun 12 '12 at 10:33

1 Answer 1

This is an incompability from xunicode (loaded by fontspec/xltxtra) and amsymb loaded by chessboard/xskak).

But imho with a current version of xunicode the problem should be solved. I don't get the error on miktex 2.9. with

\ProvidesFile{xunicode.sty}[2011/09/09 v0.981
share|improve this answer
    
Thanks a lot for your prompt answer. I have updated the older xunicode.sty, and now it works well. I'm in the process of shifting to XeLatex and to the new, unicode based, WinEdt 7. –  hhdehaan Jun 12 '12 at 11:33
    
@hhdehaan: I just realized that you are trying to use a system chess font \fontspec{FigurineCB AriesSP}. That's okay if you want single, specific symbol from a specific font but I recommend to avoid this. These fonts don't use the standard encoding expected by skak and xskak and it is not possible to reencode them with xelatex (with lualatex it will perhaps be possible in the future). It is better to stick to the standard type1 chess fonts. –  Ulrike Fischer Jun 12 '12 at 13:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.