Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm working with the elsarticle class, available here. I have a lot of figures, and it seems like the class is using something equivalent to multicol to encourage columns to be of equal lengths within any given page. This is resulting in some really horrible looking pages such as those shown in the screenshots, which show two consecutive pages.

It would be preferable in the attached examples if some of the text from the second page filled up below the right column of the first page to bring it down to the bottom of the first page.

I thought if I was using multicol myself and switched to multicol* I could at least see if turning off column equalization helped, but I can't find where to do this in elsarticle.cls.

Also, if I'm totally barking up the wrong tree here and there's a much better way to make the text fit in around the images, that would be great.

Page 2 Page 3

share|improve this question
1  
The elsarticle document class does not use the multicol package, but relies on LaTeX's "built-in" twocolumn capabilities. –  Mico Jun 13 '12 at 2:15
    
OK, so is there a way to discourage it from trying so hard to have equal-length columns? –  SSilk Jun 14 '12 at 0:01
    
whatever is happening here, without a minimal example that produces the behavior (and not just a picture of it) there is no way to tell. I'm fairly certain that you do load other package, from what I see in elsarticle the above can't be produced. –  Frank Mittelbach Jun 17 '12 at 18:47

1 Answer 1

up vote 1 down vote accepted

Well, I didn't find out how to turn off column equalization, but the issue I was having with the columns seeming to want to end line up with actually was resolved by changing the image placement indicators. Not sure if that's the correct term, but I'm talking about the [ht] component of \begin{figure}[ht]. Some time a couple years ago I read a bit about figure placement and whatever site I read recommended using [!htpb] for maximum control over the placement, i.e. to make LaTeX very likely to put it exactly where you place the code.

That worked for me at the time and I never changed it, so the image placement shown in my original question happened while using [!htpb]. When I changed it to [ht], things started rendering a lot nicer and columns no longer seem to want to stay as equalized per page as the examples I showed above.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.