TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In 7.1.1 of the PGFPLOTS library the following example of externalization is given. Whatever I try, I cannot get it to work in TeXniccenter, running MiKTeX 2.8.

\tikzexternalize% activate externalization!

\addplot {x^2};
\caption{Our first external graphics example}

I tried adding the following command line arguments to the output profile

-shell-escape -synctex=-1 -interaction=nonstopmode "%bm" 

And tried a number of other things, but I cannot get it to work. Error:

Package TiKz error: Sorry the system call 'pdflatex -halt-on-error -interaction=batchmode -jobname "plaatje-figure0" ... did NOT result in a usable output file 'plaatje-figure0'

share|improve this question
I think in MikTeX you have to compile with -enable-write18 instead of -shell-escape. So try changing that in the command line arguments and in the TeX file (\tikzexternalize[shell escape=-enable-write18]) – Caramdir Jun 15 '12 at 17:30
Note, that did not make a change. But updating to MiKTeX 2.9 did. Don't know why, though? – willem Jun 15 '12 at 17:54
I still cannot get my head around the fact that MiKTeX 2.8 would not work? I Downloaded PGF from the repository. Is the repository not updated for a fixed version of MiKTEX? – willem Jun 15 '12 at 18:19
@willem Have a look at the MikTeX manual and the release note for version 2.9. Maybe you find an explanation. – Sveinung Jun 15 '12 at 21:37
up vote 6 down vote accepted

Updating the MikTeX installation would solve the issue as I'm using the same configuration

enter image description here And the result is

enter image description here

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.