Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

When I run LaTeX2HTML on a LaTeX file, the table of contents that is generated in the html file has bullets to the left of each section.

Like this:

o  this_is_section_one
o  this_is_section_two

If I use the option -show_section_numbers then the bullets remain and next to them I see the section numbers, like for example:

o  1. this_is_section_one
o  2. this_is_section_two

What I want is a table of contents with section numbers. No Bullets, like the following:

1. this_is_section_one
2. this_is_section_two

I do not know how to get rid of the bullets.

The commands I tried are

latex2html -split 4 KERNEL.tex 
latex2html -split 4 -show_section_numbers KERNEL.tex 

In the LaTeX file itself, I tried with \tableofcontents and without \tableofcontents. Nonetheless, I still get the bullets.

The question is: how to get rid of the bullets? I hope there is an option or a flag to achieve this, but looking at the man page for LaTeX2HTML, I do not see it. Will keep trying, but I thought to ask here, in case someone knows.

share|improve this question
    
Welcome to TeX.SX! Usually, we don't put a greeting or a “thank you” in our posts. While this might seem strange at first, it is not a sign of lack of politeness, but rather part of our trying to keep everything very concise. Accepting and upvoting answers is the preferred way here to say “thank you” to users who helped you. –  Martin Schröder Nov 4 '13 at 21:22

1 Answer 1

up vote 3 down vote accepted

The problem is that the list-items have bullets by default in HTML files - expanding the LaTeX list-items bulleting/numbering.

To get rid of that default bullets from all of the lists, you need to modify the CSS file which was generated by LaTeX2HTML. Add the following code snippet to this file:

ul {
    list-style-type: none;
}

(I have not used LaTeX2HTML, but come up against the same problem while working with TeX4ht.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.