Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

It seems like the font choice is somehow embedded in the document class itself; I've tried choosing fonts the usual way, but with no effect.

share|improve this question
    
Welcome to TeX.sx! Please add a minimal working example (MWE) that illustrates your problem, showing what you tried and what doesn't work. –  doncherry Jun 16 '12 at 19:54
    
@doncherry: Ah, alright. I've seen MWEs on questions I've read before, but I didn't realize they were actually standard/required! Luckily, your renewcommand did the trick. –  texuser Jun 16 '12 at 20:51
    
They're definitely good style, and probably even essential for most questions. They definitely make it easier for other users to answer your questions, and perhaps tell potential answerers what the problem might be, just like here: A package like libertine works fine, others don't; so actually your question was imprecise in a way -- for some font packages "the usual way" works, for others it doesn't. Another policy-kind of thing here: It's good style not only to accept the answer that helped you most, but also to upvote (faq) answers that you found helpful. –  doncherry Jun 16 '12 at 20:58
    
@donecherry: Thanks! Apparently I need 15 reputation points to upvote, but I'll come back and do it if and when that happens... –  texuser Jun 16 '12 at 21:11
    
Of course, I forgot about that, my bad. –  doncherry Jun 16 '12 at 21:24
add comment

2 Answers

up vote 3 down vote accepted

This works for me:

\documentclass{sciposter}

\usepackage{libertine}
\usepackage[T1]{fontenc}

\begin{document}
\Huge Hello
\end{document}

The problem might be that you loaded a font package that doesn't provide a sans-serif font, e.g. mathpazo or fourier. In that case you need to add the following to your preamble:

\renewcommand{\familydefault}{\rmdefault}

This makes the serif font the default font. The standard for sciposter is to use the sans-serif font as default.

share|improve this answer
add comment

The class loads the (obsolete) package times and sets the default font family to sans serif (Helvetica).

If you want to use, say, the Computer Modern fonts, you have to revert the setting:

\documentclass{sciposter}

\renewcommand{\familydefault}{\rmdefault}
\renewcommand{\rmdefault}{cmr}
\renewcommand{\sfdefault}{cmss}
\renewcommand{\ttdefault}{cmtt}

However, as sciposter uses big font sizes, a scalable font may be better:

\documentclass{sciposter}

\renewcommand{\familydefault}{\rmdefault}
\usepackage{lmodern}

Alternatively, you can load a different font package:

\documentclass{sciposter}

\renewcommand{\familydefault}{\rmdefault}
\usepackage{kpfonts}

or any font package of your choice.

share|improve this answer
    
+1 This answer is extremely useful as it gives all the different options for changing fonts. –  I Like to Code Dec 17 '13 at 1:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.