Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I want to preserve the ordering of the author field and avoid the automatic abbreviations, and only that, for this specific entry.

I have something like:

@TECHREPORT{abcd2012,
  author = {Free Software Foundation},
  title = {Some study},
  year = {2012}
}

By default, it displays the author name as:

FOUNDATION, F. S.

and when I use \citeauthoronline: Foundation

I want it to display:

FREE SOFTWARE FOUNDATION

And for when I use \citeauthoronline:

Free Software Foundation

If I add an additional pair of {}, it prevents splitting, but also blocks further desired formatting from the bibliography style (capitalization). So, this solution isn't acceptable.

What I can do to achieve the desired effect?

EDIT: I forgot to mention my bibliography style, ABNTeX:

\usepackage[alf,abnt-etal-text=emph]{abntcite}
share|improve this question
    
Does either author = {Free~Software~Foundation} or author = {FREE~SOFTWARE~FOUNDATION} work for your case? –  Mico Jun 17 '12 at 10:33
1  
Would you please add the bib style you're using? A minimal working example (MWE) would be very useful. Welcome to TeX.SX! –  egreg Jun 17 '12 at 11:11
    
The ~ works the same as the simple space here. It doesn't solve the problem. I'm using the ABNTeX style, but I guess that Jellby answer works for all styles. –  ReneSac Jun 17 '12 at 14:42

2 Answers 2

up vote 5 down vote accepted

Does this work as you want?

@TECHREPORT{abcd2012,
  author = {Free{\ }Software{\ }Foundation},
  title = {Some study},
  year = {2012}
}
share|improve this answer
    
Yes, it works! Thanks. –  ReneSac Jun 17 '12 at 14:43

This isn't directly a answer to what I asked, like Jellby's was, but a way to avoid this problem altogether by doing the right thing with my style:

@TECHREPORT{abcd2012,
  organization = {Free Software Foundation},
  title = {Some study},
  year = {2012}
}

I found that changing author = {} to organization = {} results in the output I expected. The downside is that JabRef doesn't offer this option, only institution = {}, that don't works in this way with my style. That's also why I haven't discovered it sooner... So I need to manually edit the BibTeX entry, and the author field in JabRef remains empty... but still, I think it is less hackish.

I can also use org-short = {FSF} in order to define a shorter name for citations on the middle of the text, but this goes beyond my original question.

share|improve this answer
1  
This shows a good reason why a minimal example should always be included in this type of questions: it's impossible to guess the bibliography style and its interactions with the document class. –  egreg Jun 17 '12 at 15:53
    
Yeah... I thought that only the bibliographic entry and it's output was sufficient, but I forgot how diverse the bibliographic styles were... –  ReneSac Jun 17 '12 at 15:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.