Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I want to put a crossing on an edge. I do it in the following way:

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[english,russian]{babel}
\usepackage{tikz}
\usepackage{color}
\usetikzlibrary{shapes.misc}

\begin{document}
\begin{tikzpicture}
[-latex,auto,
bkeg/.style={draw=red!30}]
\draw[bkeg] (0,0) to [bend left] node [black, pos=0.3, auto=false, cross out, draw]{} (4,4);
\end{tikzpicture}

\end{document}

Here I get the crossing :

enter image description here

How to get rid of the arrow and in the second line of the crossing? Is it posible to reset this "-latex" option in the slave node?

share|improve this question
add comment

1 Answer

up vote 14 down vote accepted

Yes, you can just set - (like a line without an arrow) as a node option:

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage{tikz}
\usepackage{color}
\usetikzlibrary{shapes.misc}

\begin{document}
\begin{tikzpicture}
[-latex,auto,
bkeg/.style={draw=red!30}]
\draw[bkeg] (0,0) to [bend left] node [black, pos=0.3, auto=false, cross out, -, draw]{} (4,4);
\end{tikzpicture}

\end{document}
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.