Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

XeLaTeX has stopped including .eps files in my document. I get errors such as:

! Unable to load picture or PDF file './images/deBuitleir.fig4.eps'.

The image file is there, I double-checked.

History: Inclusion of .eps images worked fine until I did a "safe-upgrade" on Debian. Based on this and this, it seems to be a regression of an old Debian bug. Since I couldn't find a patch that fixed the problem, I removed all TeX and XeTeX packages on my Debian system and installed TeX Live from source. I then updated my path. Unfortunately, the error is still occurring, even though I have a "plain vanilla" TeX Live installation.

I really really don't want to convert all of my .eps files to another format. Does anyone know how to fix this? Thank you in advance.

Here's the MWE:

\documentclass[letter,10pt]{article}

\usepackage{graphicx}

\begin{document}

Figure 1

\includegraphics[scale=0.5,keepaspectratio=true]{./images/deBuitleir.fig1.eps}

\end{document}
share|improve this question
    
Can you post a MWE (Minimum Working Example) and .eps file to check where is the mistake. Maybe is path of figures is wrong or try changing the figure to the latex source folder –  texenthusiast Jun 18 '12 at 16:19
3  
Maybe it is trying to read fig4 as the file extension. –  percusse Jun 18 '12 at 16:33
    
That was the problem! I forgot that I also had to rename the images to satisfy the editor's naming convention. –  mhwombat Jun 18 '12 at 16:41
    
Forgot to say: When I changed the first "." to an underscore, it worked. –  mhwombat Jun 18 '12 at 16:49
    
@mhwombat: Please accept Martin Schröder's answer. –  Crowley Jun 19 '12 at 7:18

1 Answer 1

up vote 6 down vote accepted

Your file has two dots, so LaTeX sees it as .fig4.eps - which is an unknown graphics file type.

Add \usepackage[multidot]{grffile}

See also \includegraphics: Dots in filename

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.