Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using LyX 1.6.8 on Windows 7 Pro x64. Today I installed Adobe Reader X - and it doesn't work with LyX any more: Adobe Reader does not open the generated PDF after you created the PDF with LyX. It only shows a welcome dialog like "Open last files - Acrobat services - etc".

First idea of course was "file association" - But the pdf file association is alright. Double clicking a pdf works from any place (also paths with spaces).

Anyone having ideas? Confirmthis? Maybe related to some 64 bit thing?

share|improve this question
    
If its possible to send a Minimum Working Example we can diagnose the problem. Check with sumatrapdf viewer downloadable at blog.kowalczyk.info/software/sumatrapdf/…. Its good for latex needs. –  texenthusiast Jun 19 '12 at 21:47
    
Note that Reader locks open files for editing; LaTeX will throw an error if it can't write to the file. –  Sean Allred Jul 4 '13 at 17:46
add comment

3 Answers

Go to Acrobat Reader’s Edit/Preferences/General and un-check the box at the bottom that says “Enable Protected Mode at startup”.

Or use a better PDF viewer such as Sumatra which works well with LaTeX and can synchronise TeX source and PDF.

share|improve this answer
add comment

Simple steps:

  1. Close your running Lyx
  2. Open any PDF file within your computer with "right-click" - open with -> choose your Adobe Acrobat as default. Close the PDF file.
  3. Open Lyx - Tool - Preferences - Path - PATH Prefix
  4. From many paths listed, Change ONLY the path of Ghostscript to your Adobe Acrobat path. Apply - Save
  5. Tools - Reconfigure, close Lyx
  6. Reopen your Lyx file :D

DONE !

share|improve this answer
1  
Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. –  Andrew Swann Apr 12 at 7:18
add comment

The problem may be that you need to add the proper path to Adobe Reader in settings. Tools->Preferences->Paths and append the path to Adobe Reader. See the current path string that is already there and apply the same syntax (path1;path2;path3).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.