Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Following a recent update, my beamer document will no longer build. I have traced the problem to the \titlepage line.

Here is my minimal working example:

\documentclass{beamer}

\usepackage[T1]{fontenc}

\usepackage{fontspec}

\usepackage[ngerman]{babel}

\usepackage{csquotes}


\usetheme{Warsaw}

\title{Mixeransteuerung mit Leistungselektronik}
\author{Stephen Bosch}
\institute{Johannes-Schlaumeier-Universität Mömbris}
%\date{\today}



\begin{document}

\begin{frame}
    \titlepage
\end{frame}

\end{document}

The error messages are:

(./test_umrichtersteuerung.nav) ! Missing { inserted. - l.25 \end{frame} A left brace was mandatory here, so I've put one in. You might want to delete and/or insert some corrections so that I will find a matching right brace soon. (If you're confused by all this, try typing `I}' now.)

! Missing { inserted. - l.25 \end{frame} A left brace was mandatory here, so I've put one in. You might want to delete and/or insert some corrections so that I will find a matching right brace soon. (If you're confused by all this, try typing `I}' now.)

Overfull \hbox (299.25987pt too wide) detected at line 25 [] []

! Missing } inserted. } l.25 \end{frame} I've inserted something that you may have forgotten. (See the above.) With luck, this will get me unwedged. But if you really didn't forget anything, try typing `2' now; then my insertion and my current dilemma will both disappear.

! Missing } inserted. } l.25 \end{frame} I've inserted something that you may have forgotten. (See the above.) With luck, this will get me unwedged. But if you really didn't forget anything, try typing `2' now; then my insertion and my current dilemma will both disappear.

Package pgf Warning: Your graphic driver pgfsys-xetex.def does not support fadi ngs. This warning is given only once on input line 25.

(I wanted to attach my log file, but couldn't find a way to do it. Suggestions are welcome.)

So far, I have tested with \usetheme{Warsaw} and with the default (no \usetheme statement). If I use the default, it builds fine.

I am using beamer 3.18, because that is what tlmgr installed after a recent update. That's when my problems started. I can see that the current version of beamer is 3.20, but it does not appear as though that version is available to my texlive 2011, which has been frozen in preparation for the new release.

I tried manually installing it to texmf-local using the instructions I found here, but even after running mktexlsr, latex is still using 3.18.

Here are my options, as I see things:

  • find a workaround to the bug with Warsaw
  • revert to the previous version of beamer (which was working) using tlmgr restore beamer
  • install beamer 3.20 over the version currently in my texlive tree (I'm reluctant to try this on my own because I am afraid of breaking something)
  • find a way to get texlive to use my local version over the one in the distribution

Any ideas?

share|improve this question
    
It's due to the font encoding not the beamer package. –  percusse Jun 20 '12 at 23:19
    
The error is due to TeX trying to do \hbox to \bmb@boxwidth-4bp{...} which is clearly wrong syntax. –  egreg Jun 20 '12 at 23:27
    
@percusse - that doesn't explain why it worked before the update. –  Stephen Bosch Jun 20 '12 at 23:31
    
Did you also update other packages? –  percusse Jun 21 '12 at 0:17
    
do not load package fontspec and run it with pdflatex then it works –  Herbert Jun 21 '12 at 6:20
show 2 more comments

1 Answer

that must be a problem with xelatex and the line

\setbeamercolor*{titlelike}{parent=palette primary}

in the file beamercolorthemewhale.sty. If you run it with lualatex it works well! However, it makes no sense to load package fontenc when not working with pdflatex. Use

\documentclass{beamer}
\usepackage{fontspec}
\usepackage[ngerman]{babel}
\usepackage{csquotes}
\usetheme{Warsaw}
share|improve this answer
    
Thanks, Herbert. I am not sure I understand, though. I thought Type 1 fonts are part of the PDF/PS standard, and it shouldn't matter how I am generating the PDF. What happens if I want to use a T1-encoded font, for example for math? –  Stephen Bosch Jun 21 '12 at 9:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.