TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am gettting the below error.

! LaTeX Error: File `uarial.sty' not found.

How to fix this?


share|improve this question
Have you read the uarial README? It shows exactly what you need to do to install it. – Werner Jun 21 '12 at 4:46
I am installing on linux. – manish Jun 21 '12 at 5:50
up vote 5 down vote accepted

you have to install the "non free fonts" from CTAN which is easy with Linux. run in a terminal:

wget -q http://tug.org/fonts/getnonfreefonts/install-getnonfreefonts
texlua ./install-getnonfreefonts
getnonfreefonts -a

That will install Arial and others in your local texmf/ directory. It is also possible under Windows with running cmd to get a terminal window, too.

share|improve this answer
bash: ./getnonfreefonts: No such file or directory – gsamaras Feb 26 '15 at 12:51

I had the same problem. I fixed it by adding rights:

# sudo chmod u+x install-getnonfreefonts

than I ran

# sudo /home/dirk/install-getnonfreefonts -a 


# sudo /usr/local/bin/getnonfreefonts -a
share|improve this answer
Is the doubled sudo in the third instruction a typo? – Mico Mar 6 '15 at 20:46
The sudo is not needed, as install-getnonfreefonts installs the fonts in $TEXMFHOME, i.e. your own dir. And of course the path /home/dirk/ works only on your system. – Martin Schröder Mar 6 '15 at 20:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.